summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-28 16:05:56 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-28 16:05:56 +0000
commit4eaffafdd5dcec27cc908047507b919eedb7515d (patch)
treea503106abc507e1b3d1cc6e824d676a4a1a9993d /sys-boot/gnu-efi
parentRemoving package. (diff)
downloadgentoo-2-4eaffafdd5dcec27cc908047507b919eedb7515d.tar.gz
gentoo-2-4eaffafdd5dcec27cc908047507b919eedb7515d.tar.bz2
gentoo-2-4eaffafdd5dcec27cc908047507b919eedb7515d.zip
use tc-getCC
Diffstat (limited to 'sys-boot/gnu-efi')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0a.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild
index f870eed17423..025e91810bdd 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild,v 1.6 2004/07/01 21:46:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild,v 1.7 2004/10/28 16:03:31 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Library for build EFI Applications"
-SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/gnu-efi-3.0a.tar.gz"
HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/gnu-efi-3.0a.tar.gz"
-KEYWORDS="ia64 ~x86"
-SLOT="3"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64 x86"
IUSE=""
-DEPEND="virtual/libc" # don't think there's anything else
-RDEPEND="virtual/libc"
+DEPEND="virtual/libc"
src_unpack() {
- unpack ${A} && cd ${S} || die "failed to unpack"
- epatch ${FILESDIR}/gnu-efi-3.0a-lds.patch || die "epatch failed"
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gnu-efi-3.0a-lds.patch
}
src_compile() {
@@ -28,7 +28,7 @@ src_compile() {
x86) iarch=ia32 ;;
*) die "unknown architecture: $ARCH" ;;
esac
- emake CC="${CC}" ARCH=${iarch} -j1 || die "emake failed"
+ emake CC="$(tc-getCC)" ARCH=${iarch} -j1 || die "emake failed"
}
src_install() {