summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-20 18:37:45 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-20 18:37:45 +0000
commit180089effc7598023417c1ad2b6eaba84592af6d (patch)
treef52a609e9ddde584a384a6554fd67d63ab67617b /sys-boot/grub
parent(#75628) Change warning message from >=6.8.0-r2 to >=6.8.0-r4. (diff)
downloadgentoo-2-180089effc7598023417c1ad2b6eaba84592af6d.tar.gz
gentoo-2-180089effc7598023417c1ad2b6eaba84592af6d.tar.bz2
gentoo-2-180089effc7598023417c1ad2b6eaba84592af6d.zip
Updates to work with amd64's 2005.0.
(Portage version: 2.0.51-r13)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog8
-rw-r--r--sys-boot/grub/grub-0.92-r1.ebuild4
-rw-r--r--sys-boot/grub/grub-0.93.20030118.ebuild4
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild11
-rw-r--r--sys-boot/grub/grub-0.94-r2.ebuild13
-rw-r--r--sys-boot/grub/grub-0.95.20040823.ebuild13
6 files changed, 36 insertions, 17 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index a1892489faeb..a680dd444f98 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.30 2004/12/20 18:54:54 blubb Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.31 2005/01/20 18:37:45 eradicator Exp $
+
+ 20 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ grub-0.94-r1.ebuild, grub-0.94-r2.ebuild, grub-0.95.20040823.ebuild:
+ Updates to work with amd64's 2005.0.
20 Dec 2004; Simon Stelling <blubb@gentoo.org> grub-0.95.20040823.ebuild:
changed WANT_AUTOMAKE to 1.8
diff --git a/sys-boot/grub/grub-0.92-r1.ebuild b/sys-boot/grub/grub-0.92-r1.ebuild
index 0d1d4ffe96da..539f0e99a8f4 100644
--- a/sys-boot/grub/grub-0.92-r1.ebuild
+++ b/sys-boot/grub/grub-0.92-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.6 2004/07/15 02:49:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.7 2005/01/20 18:37:45 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc
diff --git a/sys-boot/grub/grub-0.93.20030118.ebuild b/sys-boot/grub/grub-0.93.20030118.ebuild
index f1d6de439d1c..f553460fa3e3 100644
--- a/sys-boot/grub/grub-0.93.20030118.ebuild
+++ b/sys-boot/grub/grub-0.93.20030118.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.93.20030118.ebuild,v 1.8 2004/06/24 22:34:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.93.20030118.ebuild,v 1.9 2005/01/20 18:37:45 eradicator Exp $
inherit mount-boot eutils flag-o-matic
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index dada5aa966a4..fba883b77590 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.13 2004/10/13 20:56:53 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.14 2005/01/20 18:37:45 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -19,9 +19,14 @@ DEPEND=">=sys-libs/ncurses-5.2-r5
>=sys-devel/autoconf-2.5"
PROVIDE="virtual/bootloader"
-src_unpack() {
+pkg_setup() {
has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+ ABI_ALLOW="x86"
+ ABI="x86"
+}
+
+src_unpack() {
unpack ${A}
cd ${S}
diff --git a/sys-boot/grub/grub-0.94-r2.ebuild b/sys-boot/grub/grub-0.94-r2.ebuild
index 1c9919cb1eac..b5c5f0f795c6 100644
--- a/sys-boot/grub/grub-0.94-r2.ebuild
+++ b/sys-boot/grub/grub-0.94-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r2.ebuild,v 1.2 2004/09/12 16:59:34 robmoss Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r2.ebuild,v 1.3 2005/01/20 18:37:45 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -11,7 +11,7 @@ SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="static"
DEPEND=">=sys-libs/ncurses-5.2-r5
@@ -19,9 +19,14 @@ DEPEND=">=sys-libs/ncurses-5.2-r5
>=sys-devel/autoconf-2.5"
PROVIDE="virtual/bootloader"
-src_unpack() {
+pkg_setup() {
has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+ ABI_ALLOW="x86"
+ ABI="x86"
+}
+
+src_unpack() {
unpack ${A}
cd ${S}
diff --git a/sys-boot/grub/grub-0.95.20040823.ebuild b/sys-boot/grub/grub-0.95.20040823.ebuild
index 92f0183d5bb2..d5164ebe0a95 100644
--- a/sys-boot/grub/grub-0.95.20040823.ebuild
+++ b/sys-boot/grub/grub-0.95.20040823.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.10 2004/12/28 11:32:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.11 2005/01/20 18:37:45 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc gnuconfig toolchain-funcs
@@ -19,9 +19,14 @@ DEPEND=">=sys-libs/ncurses-5.2-r5
>=sys-devel/autoconf-2.5"
PROVIDE="virtual/bootloader"
-src_unpack() {
- has_m32 || die "Your compiler seems to be unable to compile 32-bit code. If you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+pkg_setup() {
+ has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+
+ ABI_ALLOW="x86"
+ ABI="x86"
+}
+src_unpack() {
unpack ${A}
cd ${S}