summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2005-06-12 05:39:03 +0000
committerJoshua Kinard <kumba@gentoo.org>2005-06-12 05:39:03 +0000
commit1926e967b10e2b133e0da4a1b45291d986531c2e (patch)
tree081dc87475377b2ba650761c64c70d491454ede2 /sys-boot
parentfix HOMEPAGE (bug #92701) (diff)
downloadgentoo-2-1926e967b10e2b133e0da4a1b45291d986531c2e.tar.gz
gentoo-2-1926e967b10e2b133e0da4a1b45291d986531c2e.tar.bz2
gentoo-2-1926e967b10e2b133e0da4a1b45291d986531c2e.zip
Initial import of what is quite possibly, the best bootloader for SGI Mips systems ever. Supports disk booting of IP22, IP27, IP28, IP30, and IP32 systems.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/arcload/ChangeLog12
-rw-r--r--sys-boot/arcload/Manifest3
-rw-r--r--sys-boot/arcload/arcload-0.41.ebuild68
-rw-r--r--sys-boot/arcload/files/digest-arcload-0.411
-rw-r--r--sys-boot/arcload/metadata.xml14
5 files changed, 98 insertions, 0 deletions
diff --git a/sys-boot/arcload/ChangeLog b/sys-boot/arcload/ChangeLog
new file mode 100644
index 000000000000..907a63a73c2b
--- /dev/null
+++ b/sys-boot/arcload/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sys-boot/arcload
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/ChangeLog,v 1.1 2005/06/12 05:39:03 kumba Exp $
+
+*arcload-0.41 (12 Jun 2005)
+
+ 12 Jun 2005; Joshua Kinard <kumba@gentoo.org> +metadata.xml,
+ +arcload-0.41.ebuild:
+ Initial import of what is quite possibly, the best bootloader for SGI Mips
+ systems ever. Supports disk booting of IP22, IP27, IP28, IP30, and IP32
+ systems.
+
diff --git a/sys-boot/arcload/Manifest b/sys-boot/arcload/Manifest
new file mode 100644
index 000000000000..4704cfe28b59
--- /dev/null
+++ b/sys-boot/arcload/Manifest
@@ -0,0 +1,3 @@
+MD5 7621a3de66126feecd416faa56211189 arcload-0.41.ebuild 2094
+MD5 58a9ae7662a7e557b27a74c70106c08d metadata.xml 366
+MD5 15044a63205fe66a9f42ccf799b328fe files/digest-arcload-0.41 64
diff --git a/sys-boot/arcload/arcload-0.41.ebuild b/sys-boot/arcload/arcload-0.41.ebuild
new file mode 100644
index 000000000000..03dc0330195d
--- /dev/null
+++ b/sys-boot/arcload/arcload-0.41.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/arcload-0.41.ebuild,v 1.1 2005/06/12 05:39:03 kumba Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ARCLoad - SGI Multi-bootloader. Able to bootload many different SGI Systems."
+HOMEPAGE="http://www.linux-mips.org/wiki/index.php/ARCLoad"
+SRC_URI="http://skylark.cs.put.poznan.pl/ip30/arcload-0.41.tar.bz2"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND="sys-boot/dvhtool"
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" = "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for SGI systems. It will not work on any"
+ eerror "other types of MIPS-based systems or any other architectures"
+ echo -e ""
+ die
+ fi
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building 32-bit version (sashARCS) for IP22/IP32 ..."
+ cd ${S}
+ make MODE=M32 clean || die
+ make CC=$(tc-getCC) LD=$(tc-getLD) MODE=M32 || die
+ cp ${S}/arcload.ecoff ${WORKDIR}/sashARCS
+
+ echo -e ""
+ einfo ">>> Building 64-bit version (sash64) for IP27/IP28/IP30 ..."
+ make MODE=M64 clean || die
+ make CC=$(tc-getCC) LD=$(tc-getLD) MODE=M64 || die
+ cp ${S}/arcload ${WORKDIR}/sash64
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib/arcload
+ cp ${WORKDIR}/sashARCS ${D}/usr/lib/arcload
+ cp ${WORKDIR}/sash64 ${D}/usr/lib/arcload
+ cp ${S}/arc.cf ${D}/usr/lib/arcload
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "ARCLoad binaries copied to: /usr/lib/arcload"
+ echo -e ""
+ einfo "Use of ARCLoad is relatively easy:"
+ einfo "\t1) Determine which version you need"
+ einfo "\t\tA) sashARCS for IP22/IP32"
+ einfo "\t\tB) sash64 for IP27/IP28/IP30"
+ einfo "\t2) Copy that to the volume header using 'dvhtool'"
+ einfo "\t3) Edit /usr/lib/arcload/arc.cf to fit your specific system"
+ einfo "\t (See ${HOMEPAGE} for"
+ einfo "\t an explanation of the format of the config file)"
+ einfo "\t4) Copy the config file to the volume header with 'dvhtool'"
+ einfo "\t5) Copy any kernels to the volume header that you want to be bootable"
+ einfo "\t6) Reboot, and enjoy!"
+ echo -e ""
+}
diff --git a/sys-boot/arcload/files/digest-arcload-0.41 b/sys-boot/arcload/files/digest-arcload-0.41
new file mode 100644
index 000000000000..3ed42e589357
--- /dev/null
+++ b/sys-boot/arcload/files/digest-arcload-0.41
@@ -0,0 +1 @@
+MD5 2fc12030fa45f0bb5b8a7106fd8f7661 arcload-0.41.tar.bz2 22162
diff --git a/sys-boot/arcload/metadata.xml b/sys-boot/arcload/metadata.xml
new file mode 100644
index 000000000000..d8fbe78088c7
--- /dev/null
+++ b/sys-boot/arcload/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mips</herd>
+ <maintainer>
+ <email>mips@gentoo.org</email>
+ <name>Mips Team</name>
+ </maintainer>
+
+ <longdescription>
+ ARCLoad - SGI Multi-bootloader. Able to bootload many different SGI Systems.
+ </longdescription>
+</pkgmetadata>
+