summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-04-27 04:57:16 +0000
committerJeroen Roovers <jer@gentoo.org>2010-04-27 04:57:16 +0000
commitdece2617488acb801349cdf25637c71621e37fee (patch)
treebc9c6983085dd4696ef2e27222fb7692ed9c76c9 /sys-boot
parentdigest fix (diff)
downloadgentoo-2-dece2617488acb801349cdf25637c71621e37fee.tar.gz
gentoo-2-dece2617488acb801349cdf25637c71621e37fee.tar.bz2
gentoo-2-dece2617488acb801349cdf25637c71621e37fee.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-436.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index a5df9aa8b32e..145560925680 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.37 2010/04/19 01:02:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.38 2010/04/27 04:57:16 jer Exp $
+
+*unetbootin-436 (27 Apr 2010)
+
+ 27 Apr 2010; Jeroen Roovers <jer@gentoo.org> +unetbootin-436.ebuild:
+ Version bump.
*unetbootin-433 (19 Apr 2010)
diff --git a/sys-boot/unetbootin/unetbootin-436.ebuild b/sys-boot/unetbootin/unetbootin-436.ebuild
new file mode 100644
index 000000000000..74554155a8a6
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-436.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-436.ebuild,v 1.1 2010/04/27 04:57:16 jer Exp $
+
+inherit qt4
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_compile() {
+ lupdate unetbootin.pro || die "lupdate failed"
+ lrelease unetbootin.pro || die "lrelease failed"
+ eqmake4 unetbootin.pro || die "eqmake4 failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin unetbootin || die "dobin failed"
+ insinto /usr/share/applications
+ doins unetbootin.desktop || die "doins failed"
+}