summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-28 02:31:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-28 02:31:56 +0000
commitbc6b40bc34d39d67b7203054c4bb5f1dcdca1c61 (patch)
treeea608ae8d14aeebfea653a6fba008f06b789441a /sys-cluster
parentAdd sqlite dep. (diff)
downloadgentoo-2-bc6b40bc34d39d67b7203054c4bb5f1dcdca1c61.tar.gz
gentoo-2-bc6b40bc34d39d67b7203054c4bb5f1dcdca1c61.tar.bz2
gentoo-2-bc6b40bc34d39d67b7203054c4bb5f1dcdca1c61.zip
Merge debian patch. Support passing options to daemon, and improve init.d for BL2. Bug #371469: Fix CVE-2011-1784 pidfile perms.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/keepalived/ChangeLog11
-rw-r--r--sys-cluster/keepalived/files/conf-keepalived7
-rw-r--r--sys-cluster/keepalived/files/init-keepalived13
-rw-r--r--sys-cluster/keepalived/keepalived-1.2.2-r3.ebuild61
4 files changed, 86 insertions, 6 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index d3d836a16ce8..0b537bde78cb 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/keepalived
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.83 2011/12/10 23:51:00 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.84 2012/02/28 02:31:56 robbat2 Exp $
+
+*keepalived-1.2.2-r3 (28 Feb 2012)
+
+ 28 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> +files/conf-keepalived,
+ +keepalived-1.2.2-r3.ebuild, files/init-keepalived:
+ Merge debian patch. Support passing options to daemon, and improve init.d for
+ BL2. Bug #371469: Fix CVE-2011-1784 pidfile perms.
*keepalived-1.2.2-r2 (10 Dec 2011)
diff --git a/sys-cluster/keepalived/files/conf-keepalived b/sys-cluster/keepalived/files/conf-keepalived
new file mode 100644
index 000000000000..f1261e3753c9
--- /dev/null
+++ b/sys-cluster/keepalived/files/conf-keepalived
@@ -0,0 +1,7 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/files/conf-keepalived,v 1.1 2012/02/28 02:31:56 robbat2 Exp $
+
+# Keepalived options
+# Increase logging:
+#opts="-D"
diff --git a/sys-cluster/keepalived/files/init-keepalived b/sys-cluster/keepalived/files/init-keepalived
index c7b34c3a260f..a3f9db9ffee8 100644
--- a/sys-cluster/keepalived/files/init-keepalived
+++ b/sys-cluster/keepalived/files/init-keepalived
@@ -1,16 +1,20 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/files/init-keepalived,v 1.4 2007/04/30 06:45:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/files/init-keepalived,v 1.5 2012/02/28 02:31:56 robbat2 Exp $
depend() {
use logger
- need net
+ # The interfaces do not actually need to exist to start, it handles them gracefully.
+ use net
}
+extra_commands="checkconfig"
+
PIDFILE=/var/run/keepalived.pid
checkconfig() {
+ # keepalived has a config check command, but it does not work while the daemon is running!
if [ ! -e /etc/keepalived/keepalived.conf ] ; then
eerror "You need an /etc/keepalived/keepalived.conf file to run keepalived"
return 1
@@ -20,7 +24,8 @@ checkconfig() {
start() {
checkconfig || return 1
ebegin "Starting Keepalived"
- start-stop-daemon --start --quiet --pidfile $PIDFILE --exec /usr/sbin/keepalived
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --exec /usr/sbin/keepalived -- $opts
eend $?
}
diff --git a/sys-cluster/keepalived/keepalived-1.2.2-r3.ebuild b/sys-cluster/keepalived/keepalived-1.2.2-r3.ebuild
new file mode 100644
index 000000000000..f9e581a70555
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.2.2-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.2.2-r3.ebuild,v 1.1 2012/02/28 02:31:56 robbat2 Exp $
+
+EAPI=4
+
+inherit autotools base
+
+DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://www.keepalived.org/"
+DEBIAN_PATCH=3
+DEBIAN_A="${P/-/_}-${DEBIAN_PATCH}.diff.gz"
+SRC_URI="http://www.keepalived.org/software/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEBIAN_A}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/popt
+ sys-apps/iproute2
+ dev-libs/libnl:1.1
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.30"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1.20-do-not-need-kernel-sources.patch "${FILESDIR}"/${PN}-1.2.2-bind-afunspec.patch )
+
+DOCS=( README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO doc/keepalived.conf.SYNOPSIS )
+
+src_prepare() {
+ base_src_prepare
+ EPATCH_OPTS="-p1" epatch "${DISTDIR}"/"${DEBIAN_A}"
+ epatch "${S}"/debian/patches/*patch
+ eautoreconf
+}
+
+src_configure() {
+ STRIP=/bin/true \
+ econf \
+ --enable-vrrp \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/init-keepalived keepalived
+ newconfd "${FILESDIR}"/conf-keepalived keepalived
+
+ docinto genhash
+ dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION || die
+ # This was badly named by upstream, it's more HOWTO than anything else.
+ newdoc INSTALL INSTALL+HOWTO
+
+ # Security risk to bundle SSL certs
+ rm -f "${ED}"/etc/keepalived/samples/*.pem
+ # Clean up sysvinit files
+ rm -rf "${ED}"/etc/sysconfig "${ED}"/etc/rc.d/
+}