summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-03-24 22:30:13 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-03-24 22:30:13 +0000
commitde9a69cd097fe278dd378af9ceb505526c2b837b (patch)
tree2b533709a2dfdf43b0093e18d00088092c08cdf2 /sys-cluster
parentBug #309837: version bump. (diff)
downloadgentoo-2-de9a69cd097fe278dd378af9ceb505526c2b837b.tar.gz
gentoo-2-de9a69cd097fe278dd378af9ceb505526c2b837b.tar.bz2
gentoo-2-de9a69cd097fe278dd378af9ceb505526c2b837b.zip
Fix incorrect PBS_NODEFILE with newer glibc fix. #309755
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/maui/ChangeLog8
-rw-r--r--sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch23
-rw-r--r--sys-cluster/maui/maui-3.2.6_p21-r1.ebuild46
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-cluster/maui/ChangeLog b/sys-cluster/maui/ChangeLog
index 2a06bbabf3d9..88e092c4bd08 100644
--- a/sys-cluster/maui/ChangeLog
+++ b/sys-cluster/maui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/maui
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.14 2010/03/02 02:31:24 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.15 2010/03/24 22:30:13 jsbronder Exp $
+
+*maui-3.2.6_p21-r1 (24 Mar 2010)
+
+ 24 Mar 2010; Justin Bronder <jsbronder@gentoo.org>
+ +maui-3.2.6_p21-r1.ebuild, +files/maui-3.2.6_p21-pbs-nodefile.patch:
+ Fix incorrect PBS_NODEFILE with newer glibc fix. #309755
02 Mar 2010; Justin Bronder <jsbronder@gentoo.org> maui-3.2.6_p16.ebuild,
maui-3.2.6_p21.ebuild:
diff --git a/sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch b/sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch
new file mode 100644
index 000000000000..90bf80ca661a
--- /dev/null
+++ b/sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch
@@ -0,0 +1,23 @@
+--- maui-3.2.6p21/src/moab/MPBSI.c.orig 2010-03-16 12:54:09.000000000 +0100
++++ maui-3.2.6p21/src/moab/MPBSI.c 2010-03-16 12:57:07.000000000 +0100
+@@ -6406,6 +6406,7 @@
+ int tindex;
+
+ char tmpHostName[MAX_MLINE];
++ char tmpTaskList[MAX_MLINE+10];
+
+ mnode_t *N;
+
+@@ -6458,10 +6459,10 @@
+ }
+ else
+ {
+- sprintf(TSBuf,"%s%s:ppn=%d",
+- TSBuf,
++ snprintf (tmpTaskList,MAX_MLINE+10,"%s:ppn=%d",
+ tmpHostName,
+ NL[tindex].TC);
++ MUStrCat(TSBuf,tmpTaskList,BufSize);
+ }
+ } /* END for (tindex) */
+
diff --git a/sys-cluster/maui/maui-3.2.6_p21-r1.ebuild b/sys-cluster/maui/maui-3.2.6_p21-r1.ebuild
new file mode 100644
index 000000000000..3d52cb4ef673
--- /dev/null
+++ b/sys-cluster/maui/maui-3.2.6_p21-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.2.6_p21-r1.ebuild,v 1.1 2010/03/24 22:30:13 jsbronder Exp $
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Maui Cluster Scheduler"
+HOMEPAGE="http://www.clusterresources.com/products/maui/"
+SRC_URI="http://www.clusterresources.com/downloads/maui/${P/_/}.tar.gz"
+IUSE=""
+DEPEND="sys-cluster/torque"
+RDEPEND="${DEPEND}"
+SLOT="0"
+LICENSE="maui"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="fetch mirror"
+
+S="${WORKDIR}/${P/_/}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-autoconf-2.60-compat.patch
+ # http://www.supercluster.org/pipermail/mauiusers/2010-March/004174.html
+ epatch "${FILESDIR}"/maui-3.2.6_p21-pbs-nodefile.patch
+ sed -i \
+ -e "s~BUILDROOT=~BUILDROOT=${D}~" \
+ "${S}"/Makefile.in
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-spooldir=/usr/spool/maui || die
+ emake || die
+}
+
+src_install() {
+ make install INST_DIR="${D}/usr"
+ cd docs
+ dodoc README mauidocs.html
+}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}, obtain the file"
+ einfo "${P/_/}.tar.gz and put it in ${DISTDIR}"
+}