summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-20 00:35:30 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-20 00:35:30 +0000
commit6dbdf4bb8b9577de9cbf33de5e771160db8077f9 (patch)
treeb04bb14c242d2e8c05591a2f2f1ee05bc694b421 /sys-devel/autoconf
parentVersion bump. (diff)
downloadgentoo-2-6dbdf4bb8b9577de9cbf33de5e771160db8077f9.tar.gz
gentoo-2-6dbdf4bb8b9577de9cbf33de5e771160db8077f9.tar.bz2
gentoo-2-6dbdf4bb8b9577de9cbf33de5e771160db8077f9.zip
Add fix from upstream for type size tests #324649 by Jan Seiffert.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/ChangeLog8
-rw-r--r--sys-devel/autoconf/autoconf-2.65-r1.ebuild46
-rw-r--r--sys-devel/autoconf/files/autoconf-2.65-AC_TYPE_INT_T.patch49
3 files changed, 102 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 488957e92cdb..f681b179ed39 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.142 2010/06/04 05:32:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.143 2010/06/20 00:35:29 vapier Exp $
+
+*autoconf-2.65-r1 (20 Jun 2010)
+
+ 20 Jun 2010; Mike Frysinger <vapier@gentoo.org> +autoconf-2.65-r1.ebuild,
+ +files/autoconf-2.65-AC_TYPE_INT_T.patch:
+ Add fix from upstream for type size tests #324649 by Jan Seiffert.
04 Jun 2010; Jeroen Roovers <jer@gentoo.org> autoconf-2.65.ebuild:
Stable for HPPA (bug #311967).
diff --git a/sys-devel/autoconf/autoconf-2.65-r1.ebuild b/sys-devel/autoconf/autoconf-2.65-r1.ebuild
new file mode 100644
index 000000000000..00126b56c2f2
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.65-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.65-r1.ebuild,v 1.1 2010/06/20 00:35:30 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="2.5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-8"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-AC_TYPE_INT_T.patch #324649
+}
+
+src_compile() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+ # From configure output:
+ # Parallel builds via `make -jN' do not work.
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}
diff --git a/sys-devel/autoconf/files/autoconf-2.65-AC_TYPE_INT_T.patch b/sys-devel/autoconf/files/autoconf-2.65-AC_TYPE_INT_T.patch
new file mode 100644
index 000000000000..cc81672e427e
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.65-AC_TYPE_INT_T.patch
@@ -0,0 +1,49 @@
+https://bugs.gentoo.org/324649
+http://lists.gnu.org/archive/html/bug-autoconf/2009-12/msg00016.html
+
+From 83ee5bc460a1083ab29fd9d3a3044cbaefad6ac6 Mon Sep 17 00:00:00 2001
+From: Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
+Date: Wed, 9 Dec 2009 07:20:16 +0100
+Subject: [PATCH] Fix 2.64 AC_TYPE_INT*_T macro body text regression.
+
+* lib/autoconf/types.m4 (_AC_TYPE_INT_BODY): Move helper enum
+definition to prologue section, to avoid syntax error.
+* NEWS, THANKS: Update.
+Report by Pierre Ynard.
+
+Signed-off-by: Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
+---
+ ChangeLog | 8 ++++++++
+ NEWS | 3 +++
+ THANKS | 1 +
+ lib/autoconf/types.m4 | 12 ++++++------
+ 4 files changed, 18 insertions(+), 6 deletions(-)
+
+diff --git a/lib/autoconf/types.m4 b/lib/autoconf/types.m4
+index 7a73fc2..3829c4c 100644
+--- a/lib/autoconf/types.m4
++++ b/lib/autoconf/types.m4
+@@ -635,14 +635,14 @@ m4_define([_AC_TYPE_INT_BODY],
+ 'long long int' 'short int' 'signed char'; do
+ AC_COMPILE_IFELSE(
+ [AC_LANG_BOOL_COMPILE_TRY(
+- [AC_INCLUDES_DEFAULT],
+- [enum { N = $[]2 / 2 - 1 };
+- 0 < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)])],
++ [AC_INCLUDES_DEFAULT
++ enum { N = $[]2 / 2 - 1 };],
++ [0 < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)])],
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_BOOL_COMPILE_TRY(
+- [AC_INCLUDES_DEFAULT],
+- [enum { N = $[]2 / 2 - 1 };
+- ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)
++ [AC_INCLUDES_DEFAULT
++ enum { N = $[]2 / 2 - 1 };],
++ [($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)
+ < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 2)])],
+ [],
+ [AS_CASE([$ac_type], [int$[]2_t],
+--
+1.7.1
+