summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-01-28 03:57:31 +0000
committerNed Ludd <solar@gentoo.org>2004-01-28 03:57:31 +0000
commitdf7fb7c82e9448839b8ea8714b0790bd971ed047 (patch)
tree57a4cd42428b494bf5a29512997df31eac92cff5 /sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
parentRemoved from portage in favor of media-sound/audiocompress which (diff)
downloadgentoo-2-df7fb7c82e9448839b8ea8714b0790bd971ed047.tar.gz
gentoo-2-df7fb7c82e9448839b8ea8714b0790bd971ed047.tar.bz2
gentoo-2-df7fb7c82e9448839b8ea8714b0790bd971ed047.zip
Added support for new PT_PAX_FLAGS markings for program headers.
Diffstat (limited to 'sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild')
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild181
1 files changed, 181 insertions, 0 deletions
diff --git a/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild b/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
new file mode 100644
index 000000000000..fc90a48c1196
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild,v 1.1 2004/01/28 03:57:31 solar Exp $
+
+IUSE="nls bootstrap build"
+
+# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
+# the manpages, but seems this is incorrect ....
+
+inherit eutils libtool flag-o-matic
+
+# Generate borked binaries. Bug #6730
+filter-flags "-fomit-frame-pointer -fssa"
+
+PATCHVER="1.2"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
+ mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
+HOMEPAGE="http://sources.redhat.com/binutils/"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL-2"
+#KEYWORDS="~amd64 ~x86 ~ppc ~alpha ~sparc ~mips ~hppa ~arm ~ia64 ~ppc64"
+KEYWORDS="-*"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ !build? ( !bootstrap? ( dev-lang/perl ) )"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+
+ # The prescott patch is not ready yet.
+ mkdir ${WORKDIR}/patch/skip
+ mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
+
+ epatch ${WORKDIR}/patch
+
+ # Libtool is broken (Redhat).
+ for x in ${S}/opcodes/Makefile.{am,in}
+ do
+ cp ${x} ${x}.orig
+ gawk '
+ {
+ if ($0 ~ /LIBADD/)
+ gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
+
+ print
+ }' ${x}.orig > ${x}
+ rm -rf ${x}.orig
+ done
+}
+
+src_compile() {
+ local myconf=
+
+ use nls && \
+ myconf="${myconf} --without-included-gettext" || \
+ myconf="${myconf} --disable-nls"
+
+ # Filter CFLAGS=".. -O2 .." on arm
+ if [ "${ARCH}" = "arm" ]
+ then
+ CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
+ fi
+
+
+ # Fix /usr/lib/libbfd.la
+ elibtoolize --portage
+
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ make configure-bfd || die
+ make headers -C bfd || die
+ emake tooldir="${ROOT}/usr/bin" \
+ all || die
+
+ if [ -z "`use build`" ]
+ then
+ if [ -z "`use bootstrap`" ]
+ then
+ # Nuke the manpages to recreate them (only use this if we have perl)
+ find . -name '*.1' -exec rm -f {} \; || :
+ fi
+ # Make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ insinto /usr/include
+ doins include/libiberty.h
+
+ # c++filt is included with gcc -- what are these GNU people thinking?
+ # but not the manpage, so leave that!
+# We install it now, as gcc-3.3 do not have it any longer ...
+# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
+ # /usr/bin/strip we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ # The strip symlink gets created in the loop below
+
+ # By default ar, as, ld, nm, ranlib and strip are in two places; create
+ # symlinks. This will reduce the size of the tbz2 significantly. We also
+ # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
+ # appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x=
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv ${x} ../${CHOST}/bin/${x}
+ else
+ rm -f ${x}
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ if [ -n "${PROFILE_ARCH}" ] && \
+ [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]
+ then
+ dosym ${CHOST} /usr/${CHOST/-/64-}
+
+ for x in `ls ${D}/usr/${CHOST}/bin/`
+ do
+ [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
+ dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
+ dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
+ done
+ fi
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ # Install pre-generated manpages .. currently we do not ...
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}