summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-11-16 16:43:33 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-11-16 16:43:33 +0000
commit7ac2fa4a6c864eff37fac2c93b9a125d8a6112ed (patch)
tree8bc3882239b767f685608b510ac403f399f7da53 /sys-devel/gecc
parentmake sure the icqv7 so file gets installed as well (diff)
downloadgentoo-2-7ac2fa4a6c864eff37fac2c93b9a125d8a6112ed.tar.gz
gentoo-2-7ac2fa4a6c864eff37fac2c93b9a125d8a6112ed.tar.bz2
gentoo-2-7ac2fa4a6c864eff37fac2c93b9a125d8a6112ed.zip
version bump
Diffstat (limited to 'sys-devel/gecc')
-rw-r--r--sys-devel/gecc/ChangeLog6
-rw-r--r--sys-devel/gecc/files/digest-gecc-200211021
-rw-r--r--sys-devel/gecc/gecc-20021102.ebuild49
3 files changed, 55 insertions, 1 deletions
diff --git a/sys-devel/gecc/ChangeLog b/sys-devel/gecc/ChangeLog
index 0fd040065a59..0f84b0fb4568 100644
--- a/sys-devel/gecc/ChangeLog
+++ b/sys-devel/gecc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gecc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/ChangeLog,v 1.2 2002/11/06 06:27:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/ChangeLog,v 1.3 2002/11/16 16:43:33 mjc Exp $
+
+*<gecc-20021102> (16 Nov 2002)
+
+ 16 Nov 2002; Michael Cohen <mjc@gentoo.org> version bump.
*<gecc-20021019> (19 Oct 2002)
diff --git a/sys-devel/gecc/files/digest-gecc-20021102 b/sys-devel/gecc/files/digest-gecc-20021102
new file mode 100644
index 000000000000..1f63e46bfc18
--- /dev/null
+++ b/sys-devel/gecc/files/digest-gecc-20021102
@@ -0,0 +1 @@
+MD5 b382e6df27582a6234873d336095f941 gecc-20021102.tar.gz 154133
diff --git a/sys-devel/gecc/gecc-20021102.ebuild b/sys-devel/gecc/gecc-20021102.ebuild
new file mode 100644
index 000000000000..2e50c0594d5c
--- /dev/null
+++ b/sys-devel/gecc/gecc-20021102.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/gecc-20021102.ebuild,v 1.1 2002/11/16 16:43:06 mjc Exp $
+
+IUSE=""
+DESCRIPTION="gecc is a tool to speed up compilation of C/C++ sources. It distributes the compilation on a cluster of compilation nodes. It also caches the object files to save some unneeded work."
+HOMEPAGE="http://gecc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="sys-devel/gcc"
+RDEPEND="$DEPEND"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+# rm -rf test
+ econf || die "configure failed"
+# patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc README
+
+ dodir /usr/bin/gecc_link
+ dosym /usr/bin/gecc /usr/bin/gecc_link/gcc
+ dosym /usr/bin/gecc /usr/bin/gecc_link/g++
+ dosym /usr/bin/gecc /usr/bin/gecc_link/c++
+ dosym /usr/bin/gecc /usr/bin/gecc_link/cc
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.geccd geccd
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/env.geccd 06geccd
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc.geccd geccd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use gecc for you local compiles you will need to add"
+ einfo "/usr/bin/gecc to the front of your path, and add geccd"
+ einfo "to your default runlevel"
+ einfo
+}