summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-07-28 13:13:08 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-07-28 13:13:08 +0000
commit48cd3128b1857d18224947f7dc0bef582da6a913 (patch)
treebd0d4ec73310ad276f5c2da42e22efda90930a46 /sys-devel/libtool
parentremoved 0.3.0 (diff)
downloadgentoo-2-48cd3128b1857d18224947f7dc0bef582da6a913.tar.gz
gentoo-2-48cd3128b1857d18224947f7dc0bef582da6a913.tar.bz2
gentoo-2-48cd3128b1857d18224947f7dc0bef582da6a913.zip
apply a patch that makes it work better with autoconf 2.13
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/files/1.4/libtool.m4.patch12
-rw-r--r--sys-devel/libtool/files/digest-libtool-1.4-r11
-rw-r--r--sys-devel/libtool/libtool-1.4-r1.ebuild34
3 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/libtool/files/1.4/libtool.m4.patch b/sys-devel/libtool/files/1.4/libtool.m4.patch
new file mode 100644
index 000000000000..eb07fd3f446f
--- /dev/null
+++ b/sys-devel/libtool/files/1.4/libtool.m4.patch
@@ -0,0 +1,12 @@
+--- libtool.m4.bak Sat Jul 28 14:25:46 2001
++++ libtool.m4 Sat Jul 28 14:25:48 2001
+@@ -22,6 +22,9 @@
+ ## configuration script generated by Autoconf, you may include it under
+ ## the same distribution terms that you use for the rest of that program.
+
++# The next line was added by Bruno Haible 2001-06-08.
++builtin([undefine],[symbols])
++
+ # serial 46 AC_PROG_LIBTOOL
+ AC_DEFUN([AC_PROG_LIBTOOL],
+ [AC_REQUIRE([AC_LIBTOOL_SETUP])dnl
diff --git a/sys-devel/libtool/files/digest-libtool-1.4-r1 b/sys-devel/libtool/files/digest-libtool-1.4-r1
new file mode 100644
index 000000000000..e71ade7e6fb9
--- /dev/null
+++ b/sys-devel/libtool/files/digest-libtool-1.4-r1
@@ -0,0 +1 @@
+MD5 ad40e22c9037dc0e569668c30734bc49 libtool-1.4.tar.gz
diff --git a/sys-devel/libtool/libtool-1.4-r1.ebuild b/sys-devel/libtool/libtool-1.4-r1.ebuild
new file mode 100644
index 000000000000..e3d9abe1c10c
--- /dev/null
+++ b/sys-devel/libtool/libtool-1.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4-r1.ebuild,v 1.1 2001/07/28 13:13:08 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A shared library tool for developers"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/libtool/${A}
+ ftp://prep.ai.mit.edu/gnu/libtool/${A}"
+HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/1.4/libtool.m4.patch
+}
+
+src_compile() {
+ try ./configure --prefix=/usr --infodir=/usr/share/info --host=${CHOST}
+ try pmake
+}
+
+src_install() {
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog* NEWS \
+ README THANKS TODO doc/PLATFORMS
+}
+
+
+
+