summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-01-07 20:17:44 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-01-07 20:17:44 +0000
commit02ab6f854afd11102de546ae4eb777a252118a06 (patch)
treec07bfe69f39549a678b99c4412c5342c9f6c9b43 /sys-devel/m4
parentAdded ~alpha to KEYWORDS (diff)
downloadgentoo-2-02ab6f854afd11102de546ae4eb777a252118a06.tar.gz
gentoo-2-02ab6f854afd11102de546ae4eb777a252118a06.tar.bz2
gentoo-2-02ab6f854afd11102de546ae4eb777a252118a06.zip
depend on perl for docs
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/ChangeLog8
-rw-r--r--sys-devel/m4/files/digest-m4-1.4p-r11
-rw-r--r--sys-devel/m4/m4-1.4p-r1.ebuild62
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-devel/m4/ChangeLog b/sys-devel/m4/ChangeLog
index d169668cd3a7..4c33a671287c 100644
--- a/sys-devel/m4/ChangeLog
+++ b/sys-devel/m4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/m4
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.5 2002/12/13 11:00:39 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.6 2003/01/07 20:17:44 azarah Exp $
+
+*m4-1.4p-r1 (07 Jan 2003)
+
+ 07 Jan 2003; Martin Schlemmer <azarah@gentoo.org> m4-1.4p-r1.ebuild
+
+ Add perl depend, as its needed for docs. Should close bug #13231.
12 Dec 2002; Jan Seidel <tuxus@gentoo.org> m4-1.4p.ebuild :
Added mips to keywords.
diff --git a/sys-devel/m4/files/digest-m4-1.4p-r1 b/sys-devel/m4/files/digest-m4-1.4p-r1
new file mode 100644
index 000000000000..a8c5d9091fb0
--- /dev/null
+++ b/sys-devel/m4/files/digest-m4-1.4p-r1
@@ -0,0 +1 @@
+MD5 a40e0a64e0c0128e38b7e4892beba2cb m4-1.4ppre2.tar.gz 689255
diff --git a/sys-devel/m4/m4-1.4p-r1.ebuild b/sys-devel/m4/m4-1.4p-r1.ebuild
new file mode 100644
index 000000000000..e496152efc0e
--- /dev/null
+++ b/sys-devel/m4/m4-1.4p-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4p-r1.ebuild,v 1.1 2003/01/07 20:17:44 azarah Exp $
+
+inherit gnuconfig
+
+IUSE="nls"
+
+MY_P="${P/p/ppre2}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="GNU macro processor"
+SRC_URI="ftp://ftp.seindal.dk/gnu/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+
+DEPEND="virtual/glibc
+ sys-devel/perl
+ nls? ( sys-devel/gettext )
+ >=sys-devel/libtool-1.3.5-r2"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ use alpha && gnuconfig_update
+}
+
+src_compile() {
+ local myconf=
+
+ use nls || myconf="--disable-nls"
+
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-modules \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+# rm -rf ${D}/usr/include
+
+ dodoc AUTHORS BACKLOG ChangeLog COPYING NEWS README* THANKS TODO
+ docinto modules
+ dodoc modules/README modules/TODO
+ docinto html
+ dohtml examples/WWW/*.htm
+}
+