summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-10-02 03:35:06 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-10-02 03:35:06 +0000
commitf85ce2b83a409588b7ffa037a421bd678ee32efc (patch)
treee2b207237280e2a20a50d760859bfcb9c10399a5 /sys-devel/perl
parentchangelog update (diff)
downloadgentoo-2-f85ce2b83a409588b7ffa037a421bd678ee32efc.tar.gz
gentoo-2-f85ce2b83a409588b7ffa037a421bd678ee32efc.tar.bz2
gentoo-2-f85ce2b83a409588b7ffa037a421bd678ee32efc.zip
gtk xemacs update
Diffstat (limited to 'sys-devel/perl')
-rw-r--r--sys-devel/perl/perl-5.6.0-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-devel/perl/perl-5.6.0-r1.ebuild b/sys-devel/perl/perl-5.6.0-r1.ebuild
index 32a9ecc1dfbc..1375b2e9c443 100644
--- a/sys-devel/perl/perl-5.6.0-r1.ebuild
+++ b/sys-devel/perl/perl-5.6.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.0-r1.ebuild,v 1.3 2000/09/15 20:09:26 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.0-r1.ebuild,v 1.4 2000/10/02 03:35:06 drobbins Exp $
P=perl-5.6.0
A=${P}.tar.gz
@@ -41,10 +41,11 @@ EOF
#THIS IS USED LATER:
export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
try make
- try make test
+ make test
}
src_install() {
+ dodir /usr/bin
try make install
install -m 755 utils/pl2pm $D/usr/bin/pl2pm
export D
@@ -54,7 +55,7 @@ export D
try make all -f - <<EOF
STDH =\$(wildcard /usr/include/linux/*.h) \$(wildcard /usr/include/asm/*.h) \
- \$(wildcard /usr/include/scsi/*.h)
+ \$(wildcard /usr/include/scsi/*.h)
GCCDIR = \$(shell gcc --print-file-name include)
PERLLIB = \$(D)/usr/lib/perl5/%{perlver}%{perlrel}
@@ -65,13 +66,13 @@ H2PH = \$(PERL) \$(D)/usr/bin/h2ph -d \$(PHDIR)/
all: std-headers gcc-headers fix-config
std-headers: \$(STDH)
- cd /usr/include && \$(H2PH) \$(STDH:/usr/include/%%=%%)
+ cd /usr/include && \$(H2PH) \$(STDH:/usr/include/%%=%%)
gcc-headers: \$(GCCH)
- cd \$(GCCDIR) && \$(H2PH) \$(GCCH:\$(GCCDIR)/%%=%%)
+ cd \$(GCCDIR) && \$(H2PH) \$(GCCH:\$(GCCDIR)/%%=%%)
fix-config: \$(PHDIR)/Config.pm
- \$(PERL) -i -p -e "s|\$(D)||g;" \$<
+ \$(PERL) -i -p -e "s|\$(D)||g;" \$<
EOF