summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
commitee9370024399e437cc5bf9059862f90092726ddb (patch)
treecfedc7627885a81bc93880532501da76c862d323 /sys-devel/spython
parentMaintainence and FHS 2.1 fixes for RC4 (diff)
downloadgentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.tar.gz
gentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.tar.bz2
gentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-devel/spython')
-rw-r--r--sys-devel/spython/spython-2.0-r3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-devel/spython/spython-2.0-r3.ebuild b/sys-devel/spython/spython-2.0-r3.ebuild
new file mode 100644
index 000000000000..f7a47d63e572
--- /dev/null
+++ b/sys-devel/spython/spython-2.0-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r3.ebuild,v 1.1 2001/02/07 16:07:39 achim Exp $
+
+S=${WORKDIR}/Python-2.0
+S2=${WORKDIR}/python-fchksum-1.1
+DESCRIPTION="A really great language -- minimalist python environment"
+SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
+ http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
+
+HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
+
+DEPEND=">=sys-libs/zlib-1.1.3-r2"
+PROVIDE="virtual/python-2.0"
+
+src_unpack() {
+ unpack BeOpen-Python-2.0.tar.bz2
+ cd ${S}/Modules
+ sed -e 's:#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz:zlib zlibmodule.c -lz:' -e 's:#\*shared\*:\*static\*:' -e 's:^TKPATH=\:lib-tk:#TKPATH:' Setup.in > Setup
+ echo "fchksum fchksum.c md5_2.c" >> Setup
+ cd ${S}/Modules
+
+ cp ${FILESDIR}/pfconfig.h .
+ unpack python-fchksum-1.1.tar.gz
+
+ cd python-fchksum-1.1
+ mv md5.h ../md5_2.h
+ sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
+ sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+
+ #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
+ cd ${S}/Python
+ cp pythonrun.c pythonrun.c.orig
+ sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
+}
+
+src_compile() {
+ cd ${S}
+ export LDFLAGS=-static
+ try ./configure --prefix=/usr --without-libdb
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
+ cp Makefile Makefile.orig
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
+
+ # Parallel make does not work
+ cd ${S}
+ try make
+}
+
+src_install() {
+ dodir /usr/share/man
+ try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
+ rm ${D}/usr/bin/python
+ mv ${D}/usr/bin/python2.0 ${D}/usr/bin/spython
+ dosym spython /usr/bin/python
+}