summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-03 21:23:13 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-03 21:23:13 +0000
commit8a20b291807269dffecaea2f119194c2bd137430 (patch)
tree7664b6882c8477d87fe0ed36d0dae1d7f0adec79 /sys-devel
parentMan pages go to the right place now (diff)
downloadgentoo-2-8a20b291807269dffecaea2f119194c2bd137430.tar.gz
gentoo-2-8a20b291807269dffecaea2f119194c2bd137430.tar.bz2
gentoo-2-8a20b291807269dffecaea2f119194c2bd137430.zip
fixed info warning (added entry to /usr/share/info/dir).
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bc/bc-1.06-r2.ebuild45
-rw-r--r--sys-devel/bc/files/bc-1.06-r1-gentoo.diff101
2 files changed, 146 insertions, 0 deletions
diff --git a/sys-devel/bc/bc-1.06-r2.ebuild b/sys-devel/bc/bc-1.06-r2.ebuild
new file mode 100644
index 000000000000..9a4e1bc0516c
--- /dev/null
+++ b/sys-devel/bc/bc-1.06-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r2.ebuild,v 1.1 2001/08/03 21:23:13 chadh Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Handy console-based calculator utility"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bc/${A}
+ ftp://prep.ai.mit.edu/pub/gnu/bc/${A}"
+HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
+
+RDEPEND="virtual/glibc
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+DEPEND="$RDEPEND sys-devel/flex"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use readline`" ]
+ then
+ myconf="--with-readline"
+ fi
+ try ./configure ${myconf} --host=${CHOST} --prefix=/usr
+ try make ${MAKEOPTS}
+
+}
+
+src_install() {
+
+ into /usr
+ doinfo doc/*.info
+ dobin bc/bc dc/dc
+ doman doc/*.1
+ dodoc AUTHORS COPYING* FAQ NEWS README ChangeLog
+
+}
+
+
diff --git a/sys-devel/bc/files/bc-1.06-r1-gentoo.diff b/sys-devel/bc/files/bc-1.06-r1-gentoo.diff
new file mode 100644
index 000000000000..e70736c03b1a
--- /dev/null
+++ b/sys-devel/bc/files/bc-1.06-r1-gentoo.diff
@@ -0,0 +1,101 @@
+diff -r -C2 bc-1.06.orig/doc/bc.texi bc-1.06/doc/bc.texi
+*** bc-1.06.orig/doc/bc.texi Wed Sep 27 20:22:24 2000
+--- bc-1.06/doc/bc.texi Fri Aug 3 16:44:49 2001
+***************
+*** 14,29 ****
+ @c end tex
+
+! @titlepage
+! @title @command{bc}
+! @subtitle an arbitrary precision calculator language
+! @subtitle version 1.06
+!
+! @author Philip A. Nelson
+! @page
+
+ This manual documents @command{bc}, an arbitrary precision calculator language.
+
+ This manual is part of GNU @command{bc}.@*
+! @sp4
+ Copyright (C) 1991, 1992, 1993, 1994, 1997 Free Software Foundation, Inc.
+ 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+--- 14,26 ----
+ @c end tex
+
+! @ifinfo
+! @direntry
+! * bc: (bc). An arbitrary precision calculator language.
+! @end direntry
+
+ This manual documents @command{bc}, an arbitrary precision calculator language.
+
+ This manual is part of GNU @command{bc}.@*
+!
+ Copyright (C) 1991, 1992, 1993, 1994, 1997 Free Software Foundation, Inc.
+ 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+***************
+*** 33,42 ****
+ are preserved on all copies.
+
+! @iftex
+ Permission is granted to process this file through TeX and print the
+ results, provided the printed document carries copying permission
+ notice identical to this one except for the removal of this paragraph
+ (this paragraph not being relevant to the printed manual).
+! @end iftex
+
+ Permission is granted to copy and distribute modified versions of this
+--- 30,39 ----
+ are preserved on all copies.
+
+! @ignore
+ Permission is granted to process this file through TeX and print the
+ results, provided the printed document carries copying permission
+ notice identical to this one except for the removal of this paragraph
+ (this paragraph not being relevant to the printed manual).
+! @end ignore
+
+ Permission is granted to copy and distribute modified versions of this
+***************
+*** 49,52 ****
+--- 46,59 ----
+ except that this permission notice may be stated in a translation approved
+ by the Foundation.
++ @end ifinfo
++
++ @titlepage
++ @title @command{bc}
++ @subtitle an arbitrary precision calculator language
++ @subtitle version 1.06
++
++ @author Philip A. Nelson
++ @page
++
+
+ You may contact the author by:
+diff -r -C2 bc-1.06.orig/doc/dc.texi bc-1.06/doc/dc.texi
+*** bc-1.06.orig/doc/dc.texi Thu Aug 31 11:57:43 2000
+--- bc-1.06/doc/dc.texi Fri Aug 3 16:42:34 2001
+***************
+*** 42,47 ****
+ notice identical to this one except for the removal of this paragraph
+ (this paragraph not being relevant to the printed manual).
+-
+ @end ignore
+ Permission is granted to copy and distribute modified versions of this
+ manual under the conditions for verbatim copying, provided that the entire
+--- 42,47 ----
+ notice identical to this one except for the removal of this paragraph
+ (this paragraph not being relevant to the printed manual).
+ @end ignore
++
+ Permission is granted to copy and distribute modified versions of this
+ manual under the conditions for verbatim copying, provided that the entire
+***************
+*** 86,90 ****
+
+ @end titlepage
+- @page
+
+ @node Top, Introduction, (dir), (dir)
+--- 86,89 ----