summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-07 21:47:37 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-07 21:47:37 +0000
commitfa5138ed0502ef9c5a3c6127c9d8a87ef48f1226 (patch)
tree1482e13d7394a7ce86f71e3f23e906cd8d2b919e /sys-devel
parentocaml-3.04 (diff)
downloadgentoo-2-fa5138ed0502ef9c5a3c6127c9d8a87ef48f1226.tar.gz
gentoo-2-fa5138ed0502ef9c5a3c6127c9d8a87ef48f1226.tar.bz2
gentoo-2-fa5138ed0502ef9c5a3c6127c9d8a87ef48f1226.zip
GDB 5.1
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/ChangeLog18
-rw-r--r--sys-devel/gdb/files/digest-gdb-5.11
-rw-r--r--sys-devel/gdb/gdb-5.1.ebuild79
3 files changed, 97 insertions, 1 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 3b2a9be4a4de..2a7aa15d52c3 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for sys-devel/gdb
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.2 2002/02/07 21:47:36 karltk Exp $
+
+*gdb-5.1 (7 Feb 2002) Karl Trygve Kalleberg <karltk@gentoo.org>: gdb-5.1.ebuild files/digest-gdb-5.1
+
+ GDB, the GNU Project debugger, allows you to see what is going on `inside'
+ another program while it executes -- or what another program was doing at
+ the moment it crashed.
+
+ GDB can do four main kinds of things (plus other things in support of these)
+ to help you catch bugs in the act:
+
+ * Start your program, specifying anything that might affect its behavior.
+ * Make your program stop on specified conditions.
+ * Examine what has happened, when your program has stopped.
+ * Change things in your program, so you can experiment with correcting the effects of one bug and go on to learn about another.
+
+ GDB works on a wide variety of UNIX and non-UNIX systems.
*gdb-5.0-r2 (1 Feb 2002)
diff --git a/sys-devel/gdb/files/digest-gdb-5.1 b/sys-devel/gdb/files/digest-gdb-5.1
new file mode 100644
index 000000000000..50dbe5a1d725
--- /dev/null
+++ b/sys-devel/gdb/files/digest-gdb-5.1
@@ -0,0 +1 @@
+MD5 9604597d6c188a2a1b99dcee0333efd6 gdb-5.1.tar.bz2 10657792
diff --git a/sys-devel/gdb/gdb-5.1.ebuild b/sys-devel/gdb/gdb-5.1.ebuild
new file mode 100644
index 000000000000..12a958c8dc66
--- /dev/null
+++ b/sys-devel/gdb/gdb-5.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.1.ebuild,v 1.1 2002/02/07 21:47:37 karltk Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU debugger"
+HOMEPAGE="http://www.gnu.org/software/gdb/gdb.html"
+SRC_URI="ftp://sourceware.cygnus.com/pub/gdb/releases/${A}
+ ftp://ftp.freesoftware.com/pub/sourceware/gdb/releases/${A}"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2"
+
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-included-regex \
+ --without-included-gettext \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake
+}
+
+src_install() {
+
+ emake prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ cd gdb/doc
+ emake infodir=${D}/usr/share/info \
+ install-info || die
+
+ cd ${S}/bfd/doc
+ emake infodir=${D}/usr/share/info \
+ install-info || die
+
+ cd ${S}
+
+ # These includes and libs are in binutils already
+ rm -f ${D}/usr/lib/libbfd.*
+ rm -r ${D}/usr/lib/libiberty.*
+ rm -f ${D}/usr/lib/libopcodes.*
+
+ rm -rf ${D}/usr/include
+
+ dodoc COPYING* README
+
+ docinto gdb
+ dodoc gdb/CONTRIBUTE gdb/COPYING* gdb/README \
+ gdb/MAINTAINERS gdb/NEWS gdb/ChangeLog* \
+ gdb/TODO
+
+ docinto sim
+ dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
+
+ docinto mmalloc
+ dodoc mmalloc/COPYING.LIB mmalloc/MAINTAINERS \
+ mmalloc/ChangeLog mmalloc/TODO
+}
+
+
+
+