summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-12-11 01:05:00 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-12-11 01:05:00 +0000
commitfd1803aae3a102b4e3a6c20e8e02f40cf5982a55 (patch)
tree3037d57adb687a5f0cabf73e0f86c0f288de7271 /sys-devel
parentcool (diff)
downloadgentoo-2-fd1803aae3a102b4e3a6c20e8e02f40cf5982a55.tar.gz
gentoo-2-fd1803aae3a102b4e3a6c20e8e02f40cf5982a55.tar.bz2
gentoo-2-fd1803aae3a102b4e3a6c20e8e02f40cf5982a55.zip
fixed cpan errors
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/perl/files/Config.pm40
-rw-r--r--sys-devel/perl/perl-5.6.1-r9.ebuild6
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-devel/perl/files/Config.pm b/sys-devel/perl/files/Config.pm
new file mode 100644
index 000000000000..fed92867db53
--- /dev/null
+++ b/sys-devel/perl/files/Config.pm
@@ -0,0 +1,40 @@
+
+# This is CPAN.pm's systemwide configuration file. This file provides
+# defaults for users, and the values can be changed in a per-user
+# configuration file. The user-config file is being looked for as
+# ~/.cpan/CPAN/MyConfig.pm.
+
+$CPAN::Config = {
+ 'build_cache' => q[10],
+ 'build_dir' => q[/root/.cpan/build],
+ 'cache_metadata' => q[1],
+ 'cpan_home' => q[/root/.cpan],
+ 'ftp' => q[/usr/bin/ftp],
+ 'ftp_proxy' => q[],
+ 'getcwd' => q[cwd],
+ 'gzip' => q[/bin/gzip],
+ 'http_proxy' => q[],
+ 'inactivity_timeout' => q[0],
+ 'index_expire' => q[1],
+ 'inhibit_startup_message' => q[0],
+ 'keep_source_where' => q[/root/.cpan/sources],
+ 'lynx' => q[],
+ 'make' => q[/usr/bin/make],
+ 'make_arg' => q[],
+ 'make_install_arg' => q[],
+ 'makepl_arg' => q[],
+ 'ncftpget' => q[],
+ 'no_proxy' => q[],
+ 'pager' => q[/usr/bin/less],
+ 'prerequisites_policy' => q[ask],
+ 'scan_cache' => q[atstart],
+ 'shell' => q[/bin/bash],
+ 'tar' => q[/bin/tar],
+ 'term_is_latin' => q[1],
+ 'unzip' => q[/usr/bin/unzip],
+ 'urllist' => [],
+ 'wait_list' => [q[wait://ls6.informatik.uni-dortmund.de:1404]],
+ 'wget' => q[/usr/bin/wget],
+};
+1;
+__END__
diff --git a/sys-devel/perl/perl-5.6.1-r9.ebuild b/sys-devel/perl/perl-5.6.1-r9.ebuild
index 6dca0699e059..169a76b2c74d 100644
--- a/sys-devel/perl/perl-5.6.1-r9.ebuild
+++ b/sys-devel/perl/perl-5.6.1-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r9.ebuild,v 1.3 2002/12/10 23:08:41 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r9.ebuild,v 1.4 2002/12/11 01:05:00 mcummings Exp $
IUSE="berkdb gdbm"
@@ -190,6 +190,8 @@ src_install() {
# --man3dir=${D}/usr/share/man/man3 \
# --man3ext=3
+ # This is a poor fix for CPAN to have a default config
+ cp ${FILESDIR}/Config.pm ${D}/usr/lib/perl5/5.6.1/CPAN/
# This removes ${D} from Config.pm
@@ -213,7 +215,7 @@ pkg_postinst() {
#########################################
cd /usr/include; h2ph *.h sys/*.h
#This is an attempt to get MakeMaker into the perl build
- echo "n" | perl -MCPAN -e 'CPAN::Shell->install(ExtUtils::MakeMaker)'
+ echo "no" | perl -MCPAN -e 'CPAN::Shell->install(ExtUtils::MakeMaker)'
#########################################