summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-18 02:03:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-18 02:03:29 +0000
commit7e5435fa833fe49197384a2c5db5a9adb518c34e (patch)
tree896e3f33c134cacc2cd2afb56ac3e8d77bbdbcec /sys-freebsd
parentInitial commit for fcitx-cloudpinyin (diff)
downloadgentoo-2-7e5435fa833fe49197384a2c5db5a9adb518c34e.tar.gz
gentoo-2-7e5435fa833fe49197384a2c5db5a9adb518c34e.tar.bz2
gentoo-2-7e5435fa833fe49197384a2c5db5a9adb518c34e.zip
Set the ssp_nonshared LDADD in its bootstrapping function. Add it only with USE=build, assume we have the ldscript in place if not.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index b9687a07363e..53d37bf162e4 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.131 2012/05/18 01:48:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.132 2012/05/18 02:03:29 aballier Exp $
+
+ 18 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
+ Set the ssp_nonshared LDADD in its bootstrapping function. Add it only with
+ USE=build, assume we have the ldscript in place if not.
18 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
Preinstall headers only with USE=build
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
index 3dfec3838ddb..51a96623b363 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.17 2012/05/18 01:48:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.18 2012/05/18 02:03:29 aballier Exp $
EAPI=2
@@ -215,6 +215,7 @@ bootstrap_libssp_nonshared() {
cd "${WORKDIR}/gnu/lib/libssp/libssp_nonshared/" || die "missing libssp."
freebsd_src_compile
append-ldflags "-L${WORKDIR}/gnu/lib/libssp/libssp_nonshared/"
+ export LDADD="-lssp_nonshared"
}
src_compile() {
@@ -254,7 +255,7 @@ src_compile() {
# be outdated in the system. Assume they are fine otherwise.
use build && append-flags "-isystem '${WORKDIR}/include_proper'"
- bootstrap_libssp_nonshared
+ use build && bootstrap_libssp_nonshared
SUBDIRS="lib gnu/lib/libssp gnu/lib/libregex"
fi
@@ -264,7 +265,7 @@ src_compile() {
# Everything is now setup, build it!
for i in ${SUBDIRS} ; do
cd "${WORKDIR}/${i}/" || die "missing ${i}."
- LDADD="-lssp_nonshared" freebsd_src_compile || die "make ${i} failed"
+ freebsd_src_compile || die "make ${i} failed"
done
}