summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-01 23:05:56 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-01 23:05:56 +0000
commit83f1f3feb1b2fe426b9184d349e9f99d348f3bf9 (patch)
tree93b624d3115a343a381136e03c442ac86dff9715 /sys-fs/cryptsetup
parenttouchup fresh-install handling (diff)
downloadgentoo-2-83f1f3feb1b2fe426b9184d349e9f99d348f3bf9.tar.gz
gentoo-2-83f1f3feb1b2fe426b9184d349e9f99d348f3bf9.tar.bz2
gentoo-2-83f1f3feb1b2fe426b9184d349e9f99d348f3bf9.zip
cleanup ebuild to not suck as much and add arm/hppa/ia64/s390 #83684
(Portage version: 2.0.51.18)
Diffstat (limited to 'sys-fs/cryptsetup')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-0.1.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-0.1.ebuild b/sys-fs/cryptsetup/cryptsetup-0.1.ebuild
index 30cda08e1226..9c4e63db54aa 100644
--- a/sys-fs/cryptsetup/cryptsetup-0.1.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-0.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-0.1.ebuild,v 1.7 2005/03/01 14:57:50 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-0.1.ebuild,v 1.8 2005/03/01 23:05:56 vapier Exp $
+
+inherit kernel-mod
DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
HOMEPAGE="http://www.saout.de/misc/dm-crypt/"
@@ -8,18 +10,16 @@ SRC_URI="http://www.saout.de/misc/dm-crypt/${PN}-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc amd64"
-
-DEPEND=">=sys-libs/device-mapper-1.00.07-r1
- >=dev-libs/libgcrypt-1.1.42"
-
+KEYWORDS="amd64 arm hppa ia64 ppc s390 x86"
IUSE=""
+DEPEND=">=sys-fs/device-mapper-1.00.07-r1
+ >=dev-libs/libgcrypt-1.1.42"
+
S=${WORKDIR}/${PN}-${PV}
pkg_setup() {
- if ! grep CONFIG_DM_CRYPT /usr/src/linux/.config > /dev/null 2>&1
- then
+ if ! kernel-mod_configoption_present CONFIG_DM_CRYPT ; then
ewarn "dm-crypt is not enabled in /usr/src/linux/.config"
ewarn "please see $HOMEPAGE"
ewarn "for details on how to enable dm-crypt for your kernel"
@@ -27,17 +27,17 @@ pkg_setup() {
}
src_compile() {
- cd ${S}
-
- econf --bindir=/bin --disable-nls|| die
+ econf --bindir=/bin --disable-nls || die
- sed -i -e 's|-lgcrypt|/usr/lib/libgcrypt.a|' Makefile src/Makefile
- sed -i -e 's|-lgpg-error|/usr/lib/libgpg-error.a|' Makefile src/Makefile
+ sed -i \
+ -e 's|-lgcrypt|/usr/lib/libgcrypt.a|' \
+ -e 's|-lgpg-error|/usr/lib/libgpg-error.a|' \
+ Makefile src/Makefile
sed -i -e 's|-lpopt|/usr/lib/libpopt.a|' src/Makefile
emake || die
}
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR="${D}" install || die "install failed"
}