summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2005-02-05 15:00:51 +0000
committerChristian Andreetta <satya@gentoo.org>2005-02-05 15:00:51 +0000
commit286b612d4a1f6dc4a995d6de7888f73d9343c674 (patch)
treefead96595ed0e57a241ca6bc80e63ebfb3f2ea3f /sys-fs/unionfs
parentremove sylpheed 0.9.99-r1 and 1.0.0-r1 mask (diff)
downloadgentoo-2-286b612d4a1f6dc4a995d6de7888f73d9343c674.tar.gz
gentoo-2-286b612d4a1f6dc4a995d6de7888f73d9343c674.tar.bz2
gentoo-2-286b612d4a1f6dc4a995d6de7888f73d9343c674.zip
unionfs-1.0.8 vserver patch (previously forgotten :-) )
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-fs/unionfs')
-rw-r--r--sys-fs/unionfs/Manifest3
-rw-r--r--sys-fs/unionfs/files/unionfs-1.0.8-vserver.patch11
-rw-r--r--sys-fs/unionfs/unionfs-1.0.8.ebuild4
3 files changed, 15 insertions, 3 deletions
diff --git a/sys-fs/unionfs/Manifest b/sys-fs/unionfs/Manifest
index 264c401886c0..0ede7f02806e 100644
--- a/sys-fs/unionfs/Manifest
+++ b/sys-fs/unionfs/Manifest
@@ -1,6 +1,7 @@
-MD5 aa3e28deb76cafcbee4ce56bbbda3842 unionfs-1.0.8.ebuild 1208
+MD5 f62ee99d3c3f3ae3ab33f1535824d4b1 unionfs-1.0.8.ebuild 1207
MD5 a214d6d08824769a02032e937a434e57 ChangeLog 569
MD5 8959da33bd490fabac57869170fb5cd2 unionfs-1.0.5.ebuild 778
MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
MD5 3e8352aeb89adf9621000e68a01d1c42 files/digest-unionfs-1.0.5 64
MD5 ed43e0aa2c797f7089d0b5233c2f4a28 files/digest-unionfs-1.0.8 65
+MD5 ca0c70650ac2ad10a83bc3255de16baa files/unionfs-1.0.8-vserver.patch 520
diff --git a/sys-fs/unionfs/files/unionfs-1.0.8-vserver.patch b/sys-fs/unionfs/files/unionfs-1.0.8-vserver.patch
new file mode 100644
index 000000000000..fce687be63ee
--- /dev/null
+++ b/sys-fs/unionfs/files/unionfs-1.0.8-vserver.patch
@@ -0,0 +1,11 @@
+--- /var/tmp/portage/unionfs-1.0.8/work/unionfs-1.0.8/namei.c.orig 2005-02-03 23:41:40.891484984 +0100
++++ /var/tmp/portage/unionfs-1.0.8/work/unionfs-1.0.8/namei.c 2005-02-03 23:42:21.620293264 +0100
+@@ -67,7 +67,7 @@
+ if (IS_APPEND(dir))
+ return -EPERM;
+ if (check_sticky(dir, victim->d_inode)||IS_APPEND(victim->d_inode)||
+- IS_IMMUTABLE(victim->d_inode))
++ IS_IMMUTABLE_FILE(victim->d_inode)||IS_IMMUTABLE_LINK(victim->d_inode))
+ return -EPERM;
+ if (isdir) {
+ if (!S_ISDIR(victim->d_inode->i_mode))
diff --git a/sys-fs/unionfs/unionfs-1.0.8.ebuild b/sys-fs/unionfs/unionfs-1.0.8.ebuild
index 19659e34e138..a77f59120458 100644
--- a/sys-fs/unionfs/unionfs-1.0.8.ebuild
+++ b/sys-fs/unionfs/unionfs-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.8.ebuild,v 1.1 2005/02/05 14:06:08 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.8.ebuild,v 1.2 2005/02/05 15:00:51 satya Exp $
inherit eutils linux-mod
@@ -21,7 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
-# use vserver && epatch ${FILESDIR}/${P}-vserver.patch
+ use vserver && epatch ${FILESDIR}/${P}-vserver.patch
if ! use debug; then
echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
EXTRACFLAGS="${EXTRACFLAGS} -DNODEBUG"