summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-07-18 12:44:48 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-07-18 12:44:48 +0000
commit2a75840e7a3d285c0a688c8c48fac999c1e7c6fe (patch)
treeac9229d37e7f6cc3b3a36abaf86b842984676fc3 /sys-fs
parentCompile fixes for LVM2 and raidtools - bugs #57096 and #57373. (Manifest reco... (diff)
downloadgentoo-2-2a75840e7a3d285c0a688c8c48fac999c1e7c6fe.tar.gz
gentoo-2-2a75840e7a3d285c0a688c8c48fac999c1e7c6fe.tar.bz2
gentoo-2-2a75840e7a3d285c0a688c8c48fac999c1e7c6fe.zip
Compile fix for 2.6 headers; bug #57096.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/raidtools/ChangeLog6
-rw-r--r--sys-fs/raidtools/files/raidtools-1.00.3-2.6.Headers.patch34
-rw-r--r--sys-fs/raidtools/raidtools-1.00.3-r1.ebuild3
3 files changed, 41 insertions, 2 deletions
diff --git a/sys-fs/raidtools/ChangeLog b/sys-fs/raidtools/ChangeLog
index db4cfa9d8398..6465fbc85617 100644
--- a/sys-fs/raidtools/ChangeLog
+++ b/sys-fs/raidtools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/raidtools
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/raidtools/ChangeLog,v 1.7 2004/07/01 21:50:38 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/raidtools/ChangeLog,v 1.8 2004/07/18 12:44:48 plasmaroo Exp $
+
+ 18 Jul 2004; <plasmaroo@gentoo.org> raidtools-1.00.3-r1.ebuild,
+ +files/raidtools-1.00.3-2.6.Headers.patch:
+ Compile fix for 2.6 headers; bug #57096.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
raidtools-0.90-r2.ebuild, raidtools-1.00.3-r1.ebuild:
diff --git a/sys-fs/raidtools/files/raidtools-1.00.3-2.6.Headers.patch b/sys-fs/raidtools/files/raidtools-1.00.3-2.6.Headers.patch
new file mode 100644
index 000000000000..c574e760ffe6
--- /dev/null
+++ b/sys-fs/raidtools/files/raidtools-1.00.3-2.6.Headers.patch
@@ -0,0 +1,34 @@
+diff -ur raidtools-1.00.3/list.h raidtools-1.00.3.plasmaroo/list.h
+--- raidtools-1.00.3/list.h 2003-01-15 08:58:25.000000000 +0000
++++ raidtools-1.00.3.plasmaroo/list.h 2004-07-18 12:25:15.000000000 +0100
+@@ -14,6 +14,7 @@
+ * using the generic single-entry routines.
+ */
+
++#define _LINUX_LIST_H
+ struct list_head {
+ struct list_head *next, *prev;
+ };
+diff -ur raidtools-1.00.3/lsraid.c raidtools-1.00.3.plasmaroo/lsraid.c
+--- raidtools-1.00.3/lsraid.c 2003-01-15 08:58:25.000000000 +0000
++++ raidtools-1.00.3.plasmaroo/lsraid.c 2004-07-18 12:25:19.000000000 +0100
+@@ -40,16 +40,15 @@
+ #include <unistd.h>
+ #include <errno.h>
+
++/* Local copies of things I use - Clean up later */
++#include "list.h"
++
+ #include <linux/types.h>
+ #include <linux/major.h>
+ #include <linux/fs.h>
+ #include <linux/raid/md_u.h>
+ #include <linux/raid/md_p.h>
+
+-/* Local copies of things I use - Clean up later */
+-#include "list.h"
+-
+-
+ /*
+ * Defines
+ */
diff --git a/sys-fs/raidtools/raidtools-1.00.3-r1.ebuild b/sys-fs/raidtools/raidtools-1.00.3-r1.ebuild
index 34527ed43b32..3f4f34644be2 100644
--- a/sys-fs/raidtools/raidtools-1.00.3-r1.ebuild
+++ b/sys-fs/raidtools/raidtools-1.00.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/raidtools/raidtools-1.00.3-r1.ebuild,v 1.10 2004/07/15 03:41:16 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/raidtools/raidtools-1.00.3-r1.ebuild,v 1.11 2004/07/18 12:44:48 plasmaroo Exp $
inherit flag-o-matic eutils
@@ -21,6 +21,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/mkraid.c-gcc33.patch
+ epatch ${FILESDIR}/${P}-2.6.Headers.patch
}
src_compile() {