summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-09-28 02:17:03 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-09-28 02:17:03 +0000
commit6452ee6f380b84cd6f797a54d8bd988d61d5b964 (patch)
treeaf774068b0688e756ad5a0d01345898b41046609 /sys-kernel/hardened-sources
parentdigest fix (diff)
downloadgentoo-2-6452ee6f380b84cd6f797a54d8bd988d61d5b964.tar.gz
gentoo-2-6452ee6f380b84cd6f797a54d8bd988d61d5b964.tar.bz2
gentoo-2-6452ee6f380b84cd6f797a54d8bd988d61d5b964.zip
hardened-sources-2.6.35 based on grsec-2.2.0-2.6.35.6-201009262116
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.35.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 5fe7a209aee4..06555ea56231 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.339 2010/09/21 20:31:48 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.340 2010/09/28 02:17:03 blueness Exp $
+
+*hardened-sources-2.6.35 (28 Sep 2010)
+
+ 28 Sep 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.35.ebuild:
+ hardened-sources-2.6.35 based on grsec-2.2.0-2.6.35.6-201009262116
21 Sep 2010; Anthony G. Basile <blueness@gentoo.org>
-hardened-sources-2.6.32-r14.ebuild, -hardened-sources-2.6.32-r15.ebuild,
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.35.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.35.ebuild
new file mode 100644
index 000000000000..865052b3ad1e
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.35.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.35.ebuild,v 1.1 2010/09/28 02:17:03 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}