summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-11-20 07:43:56 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-11-20 07:43:56 +0000
commit0bdf060df2fb6e113f2470574d8b0c8d68c1d110 (patch)
treec9e7f8f691132e1678638f8687a41c8fdd5d1b58 /sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild
parentminor fix in the r5 patch (diff)
downloadgentoo-2-0bdf060df2fb6e113f2470574d8b0c8d68c1d110.tar.gz
gentoo-2-0bdf060df2fb6e113f2470574d8b0c8d68c1d110.tar.bz2
gentoo-2-0bdf060df2fb6e113f2470574d8b0c8d68c1d110.zip
All version setting for kernels is now handled by ebuilds on an individual basis, there were only about 15 which were doing none of it before, so this way we are consistent, the eclass will now simply utilize the variables as they are set in the kernel ebuilds.
Diffstat (limited to 'sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild')
-rw-r--r--sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild b/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild
index dfc88b8f99cc..d0ba1b5c2e64 100644
--- a/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild
+++ b/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild,v 1.4 2003/10/27 13:49:11 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre11.ebuild,v 1.5 2003/11/20 07:43:38 lostlogic Exp $
IUSE="build crypt evms2 aavm usagi"
@@ -18,7 +18,13 @@ IUSE="build crypt evms2 aavm usagi"
ETYPE="sources"
inherit kernel
-OKV="2.4.20"
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
+
# Documentation on the patches contained in this kernel will be installed
# to /usr/share/doc/pfeifer-sources-${PV}/patches.txt.gz