summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-12-18 18:00:44 +0000
committerBryon Roche <kain@gentoo.org>2002-12-18 18:00:44 +0000
commit1088049984e91fc828154e1a22f848da8e740dfc (patch)
tree0ec2892b6206c8c145f070789482de15f1f172a5 /sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild
parentChanged econf||die to econf (diff)
downloadgentoo-2-1088049984e91fc828154e1a22f848da8e740dfc.tar.gz
gentoo-2-1088049984e91fc828154e1a22f848da8e740dfc.tar.bz2
gentoo-2-1088049984e91fc828154e1a22f848da8e740dfc.zip
new PPC kernel. testing still needed
Diffstat (limited to 'sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild')
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild
new file mode 100644
index 000000000000..220f5e606d36
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild,v 1.1 2002/12/18 18:00:44 kain Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gentoo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://cvs.gentoo.org/~kain/ppc/patches-${KV}.tar.bz2"
+KEYWORDS="-x86 ~ppc -sparc -alpha -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC
+ [ `use crypt` ] || rm 3*
+
+ kernel_src_unpack
+
+ [ `use xfs` ] && ewarn "XFS is no longer included!"
+}