summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-05-27 00:12:35 +0000
committerBryon Roche <kain@gentoo.org>2002-05-27 00:12:35 +0000
commit83c069845fc0e09220d275a0843817c9408b6f36 (patch)
treef3ffb8195b832c7ae9a25d31a3839f59fc1177fd /sys-kernel/ppc-sources
parentHandy little command line tool for managing firewall rules. Nothing too (diff)
downloadgentoo-2-83c069845fc0e09220d275a0843817c9408b6f36.tar.gz
gentoo-2-83c069845fc0e09220d275a0843817c9408b6f36.tar.bz2
gentoo-2-83c069845fc0e09220d275a0843817c9408b6f36.zip
New PPC Kernel.
Diffstat (limited to 'sys-kernel/ppc-sources')
-rw-r--r--sys-kernel/ppc-sources/ChangeLog9
-rw-r--r--sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r42
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.19-r4.ebuild120
3 files changed, 130 insertions, 1 deletions
diff --git a/sys-kernel/ppc-sources/ChangeLog b/sys-kernel/ppc-sources/ChangeLog
index ebe5d7233513..50f0de4196eb 100644
--- a/sys-kernel/ppc-sources/ChangeLog
+++ b/sys-kernel/ppc-sources/ChangeLog
@@ -1,6 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Id: ChangeLog,v 1.2 2002/05/05 06:47:41 kain Exp $
+# $Id: ChangeLog,v 1.3 2002/05/27 00:12:35 kain Exp $
+
+*ppc-sources-2.4.19-r4 (26 May 2002)
+
+ 26 May 2002; Kain <kain@kain.org> all :
+
+ Firewire works again. This kernel implements the O(1) scheduler, XFS,
+ the rmap VM, and the HZ=1000 timer.
*ppc-sources-2.4.19-r3 <kain@kain.org> :
diff --git a/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r4 b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r4
new file mode 100644
index 000000000000..2d9699788eda
--- /dev/null
+++ b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r4
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 4e3e19c8103fbd578922a65a89790654 linux-gentoo-ppc-2.4.19-r4.patch.bz2 5215099
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.19-r4.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r4.ebuild
new file mode 100644
index 000000000000..c7c6f430546e
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r4.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Kain X <kain@gentoo.org>
+# $Id: ppc-sources-2.4.19-r4.ebuild,v 1.1 2002/05/27 00:12:35 kain Exp $
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.18
+KV=${PVR}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19-pre8-ben0
+# ati.2 Xfree86 4.2.0 DRM
+# from http://oss.sgi.com/projects/xfs:
+# SGI XFS 1.1 (Official release code -- the most thoroughly tested)
+# Selected pre8aa3 patches:
+# 72_xfs-O_DIRECT-1
+# 73_xfs-blksize-PAGE_SIZE-1
+# from http://www.zipworld.com.au/~akpm/linux/schedlat.html:
+# 2.4.19-pre7-low-latency
+# from http://www.surriel.net/patches:
+# 2.4.19p7-rmap-13a The rmap VM.
+#
+# The O(1) Scheduler.
+
+
+DESCRIPTION="Full sources for the Gentoo Linux PPC kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.sunsite.dk/projects/gentooppc/distfiles/linux-gentoo-ppc-${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+GENTOOPATCH=${DISTDIR}/linux-gentoo-ppc-${KV}.patch.bz2
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ pwd
+ bzcat ${GENTOOPATCH} | patch -p1 || die # Patch the kernel
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}