summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-03-02 15:07:45 +0000
committerChristian Birchinger <joker@gentoo.org>2003-03-02 15:07:45 +0000
commit638838f3066051a16b5361d19bb4c8ea50c92706 (patch)
tree7e80aa2803dcac9dc3b82f6bf366d1eb710ca5e0 /sys-kernel/sparc-sources
parentNew Version (diff)
downloadgentoo-2-638838f3066051a16b5361d19bb4c8ea50c92706.tar.gz
gentoo-2-638838f3066051a16b5361d19bb4c8ea50c92706.tar.bz2
gentoo-2-638838f3066051a16b5361d19bb4c8ea50c92706.zip
Added sparc-sources-2.4.20-r4 with better kgcc detection for sparc32 machines.
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r42
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.20-r4.ebuild51
3 files changed, 58 insertions, 3 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index b11a71f8cfbc..285128ccd788 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.14 2003/02/12 09:18:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.15 2003/03/02 15:07:45 joker Exp $
+
+*sparc-sources-2.4.20-r4 (02 Mar 2003)
11 Feb 2003; Christian Birchinger <joker@gentoo.org>:
- sparc-sources-2.4.20-r3.ebuild :
+ sparc-sources-2.4.20-r4.ebuild :
- Changed KEYWORDS from ~sparc to sparc
+ New version with better kgcc handling for sparc32.
*sparc-sources-2.4.20-r3 (03 Feb 2003)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r4 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r4
new file mode 100644
index 000000000000..17cb8fd92c97
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r4
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 11aaaa97380edf11bde798ce3f736934 patches-2.4.20-r4-sparc.tar.bz2 115633
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.20-r4.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r4.ebuild
new file mode 100644
index 000000000000..c4ffe56c0357
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.20-r4.ebuild,v 1.1 2003/03/02 15:07:45 joker Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the
+# same.
+KV=${PV}
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PVR}-sparc.tar.bz2"
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ kernel_src_unpack
+
+ # Automaticaly use kgcc in the main Makefile on sparc32+gcc3 machines.
+ mv Makefile Makefile.orig
+ sed 's/^CC.*= $(CROSS_COMPILE)gcc/CC = $(CROSS_COMPILE)$(shell [ "`arch`" = "sparc" -a "`gcc -dumpversion`" != "2.95.3" ] \&\& echo kgcc || echo gcc)/' <Makefile.orig >Makefile
+ rm Makefile.orig
+}