summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2004-01-22 18:09:55 +0000
committerBob Johnson <livewire@gentoo.org>2004-01-22 18:09:55 +0000
commit21ae1cf2a0b9aed4e2b0da5d4a0d4c7aacc16265 (patch)
treedf28856bde62cdedaee3e4aa233a76ef1e1fae55 /sys-kernel/xfs-sources
parentVersion bumped (diff)
downloadgentoo-2-21ae1cf2a0b9aed4e2b0da5d4a0d4c7aacc16265.tar.gz
gentoo-2-21ae1cf2a0b9aed4e2b0da5d4a0d4c7aacc16265.tar.bz2
gentoo-2-21ae1cf2a0b9aed4e2b0da5d4a0d4c7aacc16265.zip
new revision
Diffstat (limited to 'sys-kernel/xfs-sources')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog18
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r12
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.24-r1.ebuild40
3 files changed, 56 insertions, 4 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 0986adb22d0d..e8862296b75d 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,14 +1,24 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 1999-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.38 2004/01/20 22:03:37 livewire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.39 2004/01/22 18:09:55 livewire Exp $
+*xfs-sources-2.4.24-r1 (22 Jan 2004)
+
+ 22 Jan 2004; <livewire@gentoo.org>
+ xfs-sources-2.4.24-r1.ebuild:
+ pulled evms-1.2.1.
+ added device-mapper 1.0.7 for evms2 and lvm2 support.
+ bumped freeswan.
+ fixed ecc.
+ removed kdb (does this thing EVER compile???).
+
*xfs-sources-2.4.24 (20 Jan 2004)
20 Jan 2004; <livewire@gentoo.org> xfs-sources-2.4.24.ebuild,
xfs-sources-2.4.23-r1.ebuild:
- marked 2.4.23-r1 stable
- bumped to 2.4.24
- added: proconfig,ecc,speakup,forcedeth
+ marked 2.4.23-r1 stable.
+ bumped to 2.4.24.
+ added: proconfig,ecc,speakup,forcedeth.
*xfs-sources-2.4.19-r3 (07 Jan 2004)
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r1 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r1
new file mode 100644
index 000000000000..a5896036351f
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r1
@@ -0,0 +1,2 @@
+MD5 1e055c42921b2396a559d84df4c3d9aa linux-2.4.24.tar.bz2 29837818
+MD5 382291043af6e6f545dfd4cb9319de6d xfs-sources-2.4.24-r1.patch.bz2 1378159
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.24-r1.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.24-r1.ebuild
new file mode 100644
index 000000000000..f2754ee79203
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.24-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.24-r1.ebuild,v 1.1 2004/01/22 18:09:55 livewire Exp $
+
+ETYPE="sources"
+
+inherit kernel
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}-${PR}"
+KV=${OKV}${EXTRAVERSION}
+
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://dev.gentoo.org/~scox/kernels/v2.4/xfs-sources-${PV}-r1.patch.bz2"
+
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/xfs-sources-${PV}-r1.patch.bz2 | patch -p1 \
+ || die "Failed to patch kernel"
+
+ cd ${S}
+
+ make mrproper || die "make mrproper failed"
+ kernel_universal_unpack
+
+}
+