summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-06-17 22:10:15 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-06-17 22:10:15 +0000
commit188a9ac1756bff0f792e117eab74f987a031b840 (patch)
tree856c0109d8d33c17facf8ab9cea4c01a4195c7fc /sys-kernel
parentFixed ChangeLog (diff)
downloadgentoo-2-188a9ac1756bff0f792e117eab74f987a031b840.tar.gz
gentoo-2-188a9ac1756bff0f792e117eab74f987a031b840.tar.bz2
gentoo-2-188a9ac1756bff0f792e117eab74f987a031b840.zip
Fix kbd on PPC, bounds-checking on AMD64, and C++-happiness for list.h.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/ChangeLog8
-rw-r--r--sys-kernel/linux-headers/files/digest-linux-headers-2.6.11-r2 (renamed from sys-kernel/linux-headers/files/digest-linux-headers-2.6.11-r1)0
-rw-r--r--sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch41
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild (renamed from sys-kernel/linux-headers/linux-headers-2.6.11-r1.ebuild)2
4 files changed, 49 insertions, 2 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index 3ef69894566a..e37d9184efa4 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.127 2005/05/29 23:01:09 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.128 2005/06/17 22:10:15 plasmaroo Exp $
+
+*linux-headers-2.6.11-r2 (17 Jun 2005)
+
+ 17 Jun 2005; <plasmaroo@gentoo.org> -linux-headers-2.6.11-r1.ebuild,
+ +linux-headers-2.6.11-r2.ebuild, files/linux-headers-2.6.11-appCompat.patch:
+ Fix kbd on PPC, bounds-checking on AMD64, and C++-happiness for list.h.
*linux-headers-2.6.11-r1 (29 May 2005)
diff --git a/sys-kernel/linux-headers/files/digest-linux-headers-2.6.11-r1 b/sys-kernel/linux-headers/files/digest-linux-headers-2.6.11-r2
index ea119c2440da..ea119c2440da 100644
--- a/sys-kernel/linux-headers/files/digest-linux-headers-2.6.11-r1
+++ b/sys-kernel/linux-headers/files/digest-linux-headers-2.6.11-r2
diff --git a/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch b/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
index c979ed5a75fd..1b735b4531de 100644
--- a/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
+++ b/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
@@ -642,6 +642,18 @@ diff -ur linux-2.6.6/include/asm-ppc/signal.h linux-2.6.6-gentoo/include/asm-ppc
diff -ur linux-2.6.6/include/asm-x86_64/processor.h linux-2.6.6-gentoo/include/asm-x86_64/processor.h
--- linux-2.6.6/include/asm-x86_64/processor.h 2004-06-02 19:25:24.000000000 +0100
+++ linux-2.6.6-gentoo/include/asm-x86_64/processor.h 2004-06-02 19:24:31.000000000 +0100
+@@ -136,7 +136,11 @@
+ * enable), so that any CPU's that boot up
+ * after us can get the correct flags.
+ */
++#ifndef __BOUNDS_CHECKING_ON
+ extern unsigned long mmu_cr4_features;
++#else
++unsigned long mmu_cr4_features;
++#endif
+
+ static inline void set_in_cr4 (unsigned long mask)
+ {
@@ -189,17 +189,17 @@
#define INVALID_IO_BITMAP_OFFSET 0x8000
@@ -1543,6 +1555,24 @@ diff -up linux-2.6.11/include/linux/list.h linux-2.6.11-gentoo/include/linux/lis
}
/**
+@@ -219,12 +219,12 @@
+ *
+ * The old entry will be replaced with the new entry atomically.
+ */
+-static inline void list_replace_rcu(struct list_head *old, struct list_head *new){
+- new->next = old->next;
+- new->prev = old->prev;
++static inline void list_replace_rcu(struct list_head *old, struct list_head *_new){
++ _new->next = old->next;
++ _new->prev = old->prev;
+ smp_wmb();
+- new->next->prev = new;
+- new->prev->next = new;
++ _new->next->prev = _new;
++ _new->prev->next = _new;
+ }
+
+ /**
@@ -244,15 +244,6 @@
}
@@ -2588,6 +2618,17 @@ diff -ur linux-2.6.11/include/asm-ia64/thread_info.h linux-2.6.11-gentoo/include
typedef __signed__ long long __s64;
typedef unsigned long long __u64;
#endif
+--- linux-2.6.11/include/asm-ppc/types.h 2005-03-02 07:37:31.000000000 +0000
++++ linux-2.6.11-gentoo/include/asm-ppc/types.h 2005-05-29 23:42:46.000000000 +0100
+@@ -19,7 +19,7 @@
+ typedef __signed__ int __s32;
+ typedef unsigned int __u32;
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
++#if defined(__GNUC__)
+ typedef __signed__ long long __s64;
+ typedef unsigned long long __u64;
+ #endif
--- linux-2.6.11/include/linux/unistd.h 2005-05-24 14:58:11.000000000 +0100
+++ linux-2.6.11-gentoo/include/linux/unistd.h 2005-05-29 23:45:34.000000000 +0100
@@ -1,7 +1,7 @@
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.11-r1.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild
index 6cbf4cd7f1ea..be2e1eff590f 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.11-r1.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r1.ebuild,v 1.1 2005/05/29 23:01:09 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild,v 1.1 2005/06/17 22:10:15 plasmaroo Exp $
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arm hppa m68k ia64 ppc ppc64 s390 sh sparc x86"