summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-01-18 18:01:25 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-01-18 18:01:25 +0000
commit250784179e8af140eb7e31efbf5eed4c395b5ed2 (patch)
treeea688bff65213d799b010e3f25388744da7c1c28 /sys-kernel
parentVersion bumped. (diff)
downloadgentoo-2-250784179e8af140eb7e31efbf5eed4c395b5ed2.tar.gz
gentoo-2-250784179e8af140eb7e31efbf5eed4c395b5ed2.tar.bz2
gentoo-2-250784179e8af140eb7e31efbf5eed4c395b5ed2.zip
fix0r -mm patch stuff
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/development-sources/ChangeLog8
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.59-r1.ebuild106
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.59-r2.ebuild106
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.59.ebuild28
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.59-r12
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.59-r22
6 files changed, 245 insertions, 7 deletions
diff --git a/sys-kernel/development-sources/ChangeLog b/sys-kernel/development-sources/ChangeLog
index 922cef4a4ffe..2fe7177e01fd 100644
--- a/sys-kernel/development-sources/ChangeLog
+++ b/sys-kernel/development-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/development-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/ChangeLog,v 1.6 2003/01/15 08:36:59 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/ChangeLog,v 1.7 2003/01/18 18:01:25 lostlogic Exp $
+
+*development-sources-2.5.59-r2 (18 Jan 2003)
+
+ 18 Jan 2003; Brandon Low <lostlogic@gentoo.org> development-sources-2.5.59*.ebuild:
+ Make development-sources-2.5.##.ebuild plain development-sources and
+ development-sources-2.5.##-r#.ebuild be the corresponding -mm patch.
*development-sources-2.5.58 (15 Jan 2003)
diff --git a/sys-kernel/development-sources/development-sources-2.5.59-r1.ebuild b/sys-kernel/development-sources/development-sources-2.5.59-r1.ebuild
new file mode 100644
index 000000000000..1b24d3f7e0b2
--- /dev/null
+++ b/sys-kernel/development-sources/development-sources-2.5.59-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.59-r1.ebuild,v 1.1 2003/01/18 18:01:25 lostlogic Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+if [ "${PR}" != "r0" ]; then
+ PATCH_URI="http://www.zipworld.com.au/~akpm/linux/patches/2.5/${PV}/${PVR/r/mm}/${PVR/r/mm}.gz"
+fi
+KV=${PVR/r/mm}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# beta 2.5.59 kernel sources with the -mm1 patch.
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2 ${PATCH_URI}"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="x86 ppc"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl
+ >sys-apps/module-init-tools-0.9.8
+ sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ if [ "${PATCH_URI}" ]; then
+ mv linux-${OKV} linux-${KV}
+ cd ${S}
+ zcat ${DISTDIR}/${PVR/r/mm}.gz | patch -p1 -l || \
+ die "akpm patch application failure"
+ sed -e "s:^EXTRAVERSION.*$:EXTRAVERSION = -${PR/r/mm}:" \
+ Makefile > Makefile.new
+ mv Makefile.new Makefile
+ else
+ cd ${S}
+ fi
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ fi
+}
diff --git a/sys-kernel/development-sources/development-sources-2.5.59-r2.ebuild b/sys-kernel/development-sources/development-sources-2.5.59-r2.ebuild
new file mode 100644
index 000000000000..0300be1357bb
--- /dev/null
+++ b/sys-kernel/development-sources/development-sources-2.5.59-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.59-r2.ebuild,v 1.1 2003/01/18 18:01:25 lostlogic Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+if [ "${PR}" != "r0" ]; then
+ PATCH_URI="http://www.zipworld.com.au/~akpm/linux/patches/2.5/${PV}/${PVR/r/mm}/${PVR/r/mm}.gz"
+fi
+KV=${PVR/r/mm}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# beta 2.5.59 kernel sources with the -mm1 patch.
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2 ${PATCH_URI}"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="x86 ppc"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl
+ >sys-apps/module-init-tools-0.9.8
+ sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ if [ "${PATCH_URI}" ]; then
+ mv linux-${OKV} linux-${KV}
+ cd ${S}
+ zcat ${DISTDIR}/${PVR/r/mm}.gz | patch -p1 -l || \
+ die "akpm patch application failure"
+ sed -e "s:^EXTRAVERSION.*$:EXTRAVERSION = -${PR/r/mm}:" \
+ Makefile > Makefile.new
+ mv Makefile.new Makefile
+ else
+ cd ${S}
+ fi
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ fi
+}
diff --git a/sys-kernel/development-sources/development-sources-2.5.59.ebuild b/sys-kernel/development-sources/development-sources-2.5.59.ebuild
index ae119e1986dc..7b6ae0e495c7 100644
--- a/sys-kernel/development-sources/development-sources-2.5.59.ebuild
+++ b/sys-kernel/development-sources/development-sources-2.5.59.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.59.ebuild,v 1.1 2003/01/17 17:27:30 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.59.ebuild,v 1.2 2003/01/18 18:01:25 lostlogic Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
OKV=${PV}
-KV=${PV}
+if [ "${PR}" != "r0" ]; then
+ PATCH_URI="http://www.zipworld.com.au/~akpm/linux/patches/2.5/${PV}/${PVR/r/mm}/${PVR/r/mm}.gz"
+fi
+KV=${PVR/r/mm}
S=${WORKDIR}/linux-${KV}
ETYPE="sources"
@@ -16,7 +19,7 @@ ETYPE="sources"
# beta 2.5.59 kernel sources with the -mm1 patch.
DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2 http://www.zipworld.com.au/~akpm/linux/patches/2.5/${PV}/${PV}-mm1/${PV}-mm1.gz"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2 ${PATCH_URI}"
PROVIDE="virtual/linux-sources"
HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
LICENSE="GPL-2"
@@ -27,7 +30,9 @@ if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
then
#console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl
+ >sys-apps/module-init-tools-0.9.8
+ sys-devel/make"
fi
[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
@@ -35,8 +40,19 @@ fi
src_unpack() {
cd ${WORKDIR}
unpack linux-${OKV}.tar.bz2
- cd ${S}
- zcat ${DISTDIR}/${PV}-mm1.gz | patch -p1 -l || die "akpm patch application failure"
+
+ if [ "${PATCH_URI}" ]; then
+ mv linux-${OKV} linux-${KV}
+ cd ${S}
+ zcat ${DISTDIR}/${PVR/r/mm}.gz | patch -p1 -l || \
+ die "akpm patch application failure"
+ sed -e "s:^EXTRAVERSION.*$:EXTRAVERSION = -${PR/r/mm}:" \
+ Makefile > Makefile.new
+ mv Makefile.new Makefile
+ else
+ cd ${S}
+ fi
+
#sometimes we have icky kernel symbols; this seems to get rid of them
make mrproper || die
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.59-r1 b/sys-kernel/development-sources/files/digest-development-sources-2.5.59-r1
new file mode 100644
index 000000000000..0e4f38d899cb
--- /dev/null
+++ b/sys-kernel/development-sources/files/digest-development-sources-2.5.59-r1
@@ -0,0 +1,2 @@
+MD5 f574000bfc8b602d0b618629ad3b001d linux-2.5.59.tar.bz2 31683004
+MD5 6d520f72f86c377b69eec0e5759c00ac 2.5.59-mm1.gz 69860
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.59-r2 b/sys-kernel/development-sources/files/digest-development-sources-2.5.59-r2
new file mode 100644
index 000000000000..4ad08005ba69
--- /dev/null
+++ b/sys-kernel/development-sources/files/digest-development-sources-2.5.59-r2
@@ -0,0 +1,2 @@
+MD5 f574000bfc8b602d0b618629ad3b001d linux-2.5.59.tar.bz2 31683004
+MD5 ed85e89b0bf9827f733654bfeff283c9 2.5.59-mm2.gz 102344