summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-05-25 15:27:01 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-05-25 15:27:01 +0000
commitad1b5c0e0182d1fcf13972d93745306f45a772fb (patch)
tree1204d0d8415edc030f2f1eb058562d3c4add68c9 /sys-libs/db
parentnow uses mirror://kernel (diff)
downloadgentoo-2-ad1b5c0e0182d1fcf13972d93745306f45a772fb.tar.gz
gentoo-2-ad1b5c0e0182d1fcf13972d93745306f45a772fb.tar.bz2
gentoo-2-ad1b5c0e0182d1fcf13972d93745306f45a772fb.zip
Make java bindings work with db-4
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/Manifest6
-rw-r--r--sys-libs/db/db-4.0.14.ebuild9
-rw-r--r--sys-libs/db/db-4.1.24.ebuild9
4 files changed, 24 insertions, 6 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 5a9f2578a8e4..26743c967361 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.27 2003/05/24 11:48:05 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.28 2003/05/25 15:26:52 pauldv Exp $
+
+ 25 May 2003; Paul de Vrieze <pauldv@gentoo.org> db-4.0.14.ebuild,
+ db-4.1.24.ebuild:
+ Make java work with db-4{0,1}
*db-3.2.9-r5 (24 May 2003)
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index 4228f4c70473..7a367ca46cd6 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -1,12 +1,12 @@
-MD5 06ae7922aa8825ca0844b604d0217ffc ChangeLog 4563
+MD5 08d047e6d629876a8d01b81767c6fa08 ChangeLog 4684
MD5 4e148693b2d6fe0b1e66a8724cbfc20c db-1.85-r1.ebuild 1411
MD5 744542679cd64194e3ac9e84e5f7056e db-3.2.3h-r4.ebuild 2455
MD5 4be311009c1216a911e76dcf33bb568d db-3.2.9-r1.ebuild 2587
MD5 e03298e927335414c7db1882f24ed8e4 db-3.2.9-r2.ebuild 3221
MD5 af7ea3ee5a3a001d516413c0b9bc52e5 db-3.2.9.ebuild 2464
MD5 2dd3cac46936c5510bf2133977ff5a48 db-3.3.11.ebuild 2408
-MD5 4101b40582142f95368a0cd1ae5a23e3 db-4.1.24.ebuild 1900
-MD5 6fa4e401e7d17f138554e9184f719571 db-4.0.14.ebuild 2054
+MD5 6903e4ed5bc615ee365e0ac1717f891c db-4.1.24.ebuild 2134
+MD5 1047f2b71b3f1ad40499b7a3c94a9549 db-4.0.14.ebuild 2288
MD5 a3ebfde5d24f01508f90c375a4bc1140 db-3.2.9-r5.ebuild 4033
MD5 194200b3295b95b46b4564980af27f1f files/db-3.2.9-fix-dep-link.patch 1005
MD5 ecd81fa9868ec49c61306444144d44a9 files/db.1.85.patch 55584
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
index 3b5a8b3d927a..cf6ddb02106a 100644
--- a/sys-libs/db/db-4.0.14.ebuild
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.16 2003/05/24 12:18:37 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.17 2003/05/25 15:26:52 pauldv Exp $
IUSE="tcltk java"
@@ -27,6 +27,11 @@ src_compile() {
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
|| myconf="${myconf} --disable-tcl"
+ if [ -n "${JAVAC}" ]; then
+ export JAVAC=`basename ${JAVAC}`
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ fi
+
../dist/configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -71,6 +76,8 @@ fix_so () {
[ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ target=`find -type f -maxdepth 1 -name "libdb_java*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_java.so
cd -
cd /usr/include
target=`ls db? |tail -n 1`
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index bc9fc02ec27d..c1e3c5434316 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.11 2003/05/24 12:18:37 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.12 2003/05/25 15:26:52 pauldv Exp $
IUSE="tcltk java"
@@ -27,6 +27,11 @@ src_compile() {
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
|| myconf="${myconf} --disable-tcl"
+ if [ -n "${JAVAC}" ]; then
+ export JAVAC=`basename ${JAVAC}`
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ fi
+
../dist/configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -66,6 +71,8 @@ fix_so () {
[ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ target=`find -type f -maxdepth 1 -name "libdb_java*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_java.so
cd -
cd /usr/include
target=`ls db? |tail -n 1`