summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-12-22 11:20:31 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-12-22 11:20:31 +0000
commitede0a5dd9d8879daa07f680e999e8ba365c1b2c6 (patch)
tree3c47115483991257ba37e6242cd181e56dde9979 /sys-libs/db
parentAdd db-4.2 to the package mask for testing (diff)
downloadgentoo-2-ede0a5dd9d8879daa07f680e999e8ba365c1b2c6.tar.gz
gentoo-2-ede0a5dd9d8879daa07f680e999e8ba365c1b2c6.tar.bz2
gentoo-2-ede0a5dd9d8879daa07f680e999e8ba365c1b2c6.zip
New upstream version. Some testing will be required though
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog9
-rw-r--r--sys-libs/db/db-4.2.52_p1.ebuild129
-rw-r--r--sys-libs/db/files/db-4.2-jarlocation.patch16
-rw-r--r--sys-libs/db/files/digest-db-4.2.52_p12
4 files changed, 155 insertions, 1 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 00ea617f89b2..e29e8481be96 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.74 2003/12/21 16:50:51 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.75 2003/12/22 11:20:31 pauldv Exp $
+
+*db-4.2.52_p1 (22 Dec 2003)
+
+ 22 Dec 2003; <paul@gentoo.org> db-4.2.52_p1.ebuild,
+ files/db-4.2-jarlocation.patch:
+ New upstream version. It is for now still masked for testing. There should be
+ no problems though.
21 Dec 2003; Brad House <brad_mssw@gentoo.org> db-4.1.25_p1-r3.ebuild:
mark stable on amd64
diff --git a/sys-libs/db/db-4.2.52_p1.ebuild b/sys-libs/db/db-4.2.52_p1.ebuild
new file mode 100644
index 000000000000..1f8ad571bc27
--- /dev/null
+++ b/sys-libs/db/db-4.2.52_p1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p1.ebuild,v 1.1 2003/12/22 11:20:31 pauldv Exp $
+
+IUSE="tcltk java doc"
+
+inherit eutils gnuconfig
+inherit db
+
+#Number of official patches
+PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+if [ "${PATCHNO}" == "${PV}" ]; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S=${WORKDIR}/${MY_P}/build_unix
+DESCRIPTION="Berkeley DB"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${MY_P}.tar.gz"
+
+for (( i=1 ; i<=$PATCHNO ; i++ ))
+do
+ export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+HOMEPAGE="http://www.sleepycat.com"
+SLOT="4.2"
+LICENSE="DB"
+KEYWORDS="~x86"
+
+DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+ java? ( virtual/jdk )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${WORKDIR}/${MY_P}
+ for (( i=1 ; i<=$PATCHNO ; i++ ))
+ do
+ patch -p0 <${DISTDIR}/patch.${MY_PV}.${i}
+ done
+ epatch ${FILESDIR}/${PN}-${SLOT}-jarlocation.patch
+
+ epatch ${FILESDIR}/${PN}-4.0.14-fix-dep-link.patch
+
+}
+
+src_compile() {
+ addwrite /proc/self/maps
+
+ # Mips needs a gnuconfig update so obscure things like mips64 are known
+ # db-4.1.25_p1 extracts to ${WORKDIR}/db-4.1.25, so we need to strip the _p1
+ if use mips; then
+ einfo "Updating config.{guess,sub} for mips"
+ local OLDS="${S}"
+ S="${S}/dist"
+ gnuconfig_update
+ S="${OLDS}"
+ fi
+
+
+ local myconf="--enable-rpc"
+
+ use java \
+ && myconf="${myconf} --enable-java" \
+ || myconf="${myconf} --disable-java"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ || myconf="${myconf} --disable-tcl"
+
+ if use java && [ -n "${JAVAC}" ]; then
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ export JAVAC=`basename ${JAVAC}`
+ fi
+
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ myconf="${myconf} --host=${CHOST}"
+ fi
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-compat185 \
+ --enable-cxx \
+ --with-uniquename \
+ ${myconf} || die
+
+ emake || make || die
+}
+
+src_install () {
+
+ einstall || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+
+ dodir /usr/sbin
+ mv ${D}/usr/bin/berkeley_db_svc ${D}/usr/sbin/berkeley_db42_svc
+
+ if use java; then
+ mkdir -p ${D}/usr/share/db
+ cat <<EOF >${D}/usr/share/db/package.env
+DESCRIPTION=The java bindings for berkeley db version ${MY_PV}
+CLASSPATH=:/usr/lib/db-${SLOT}.jar
+EOF
+ fi
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
diff --git a/sys-libs/db/files/db-4.2-jarlocation.patch b/sys-libs/db/files/db-4.2-jarlocation.patch
new file mode 100644
index 000000000000..600f48a3a6d6
--- /dev/null
+++ b/sys-libs/db/files/db-4.2-jarlocation.patch
@@ -0,0 +1,16 @@
+diff -ur db-4.1.25.old/dist/Makefile.in db-4.1.25/dist/Makefile.in
+--- db-4.1.25.old/dist/Makefile.in 2003-10-18 02:15:45.000000000 -0700
++++ db-4.1.25/dist/Makefile.in 2003-10-18 02:13:47.000000000 -0700
+@@ -107,9 +107,9 @@
+ JAVA_EXDIR= $(JAVA_SRCDIR)/$(JAVA_EXREL)
+ JAVA_RPCDIR= $(srcdir)/rpc_server/java
+
+-libj_jarfile= db.jar
+-libj_exjarfile= dbexamples.jar
+-rpc_jarfile= dbsvc.jar
++libj_jarfile= db-4.2.jar
++libj_exjarfile= dbexamples-4.2.jar
++rpc_jarfile= dbsvc-4.2.jar
+ libjso_base= libdb_java
+ libjso= $(libjso_base)-$(SOVERSION).@JMODSUFFIX@
+ libjso_static= $(libjso_base)-$(SOVERSION).a
diff --git a/sys-libs/db/files/digest-db-4.2.52_p1 b/sys-libs/db/files/digest-db-4.2.52_p1
new file mode 100644
index 000000000000..754c130beff8
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.2.52_p1
@@ -0,0 +1,2 @@
+MD5 cbc77517c9278cdb47613ce8cb55779f db-4.2.52.tar.gz 4073147
+MD5 1227f5f9ff43d48b5b1759e113a1c2d7 patch.4.2.52.1 988