summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-26 00:53:09 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-26 00:53:09 +0000
commit334919c4403c4fc750376444d7ff08b37f5720ca (patch)
treefde83f8d5b792ed0d0a952fc710d77b8b5f4a587 /sys-libs/glibc
parentbugfixes (diff)
downloadgentoo-2-334919c4403c4fc750376444d7ff08b37f5720ca.tar.gz
gentoo-2-334919c4403c4fc750376444d7ff08b37f5720ca.tar.bz2
gentoo-2-334919c4403c4fc750376444d7ff08b37f5720ca.zip
add ctype compat patch
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog13
-rw-r--r--sys-libs/glibc/files/2.3.1/glibc-2.3.1-ctype-compat.patch16
-rw-r--r--sys-libs/glibc/files/digest-glibc-2.3.1-r1 (renamed from sys-libs/glibc/files/digest-glibc-2.3.1)0
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r1.ebuild (renamed from sys-libs/glibc/glibc-2.3.1.ebuild)13
4 files changed, 40 insertions, 2 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 71356d945843..817daaa0638d 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.20 2002/10/13 21:56:33 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.21 2002/10/26 00:53:09 azarah Exp $
+
+*glibc-2.3.1-r1 (26 Oct 2002)
+
+ 26 Oct 2002; Martin Schlemmer <azarah@gentoo.org> glibc-2.3.1-r1.ebuild :
+
+ Add the ctype-compat.patch to fix unresolved symbols in old static binaries
+ and libraries. See bug #8766, #9586 and:
+
+ http://lists.debian.org/debian-glibc/2002/debian-glibc-200210/msg00093.html
+
+ We should think about remoing it in the future after things have settled.
*glibc-2.2.5-r7 (13 Oct 2002)
diff --git a/sys-libs/glibc/files/2.3.1/glibc-2.3.1-ctype-compat.patch b/sys-libs/glibc/files/2.3.1/glibc-2.3.1-ctype-compat.patch
new file mode 100644
index 000000000000..8e07aa068291
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.1/glibc-2.3.1-ctype-compat.patch
@@ -0,0 +1,16 @@
+--- glibc-2.3.1/ctype/ctype-info.c.orig 2002-10-26 02:12:56.000000000 +0200
++++ glibc-2.3.1/ctype/ctype-info.c 2002-10-26 02:14:53.000000000 +0200
+@@ -55,11 +55,13 @@
+ const __uint32_t *__ctype32_tolower = b (__uint32_t, tolower, 128);
+ const __uint32_t *__ctype32_toupper = b (__uint32_t, toupper, 128);
+
++#if 0
+ compat_symbol (libc, __ctype_b, __ctype_b, GLIBC_2_0);
+ compat_symbol (libc, __ctype_tolower, __ctype_tolower, GLIBC_2_0);
+ compat_symbol (libc, __ctype_toupper, __ctype_toupper, GLIBC_2_0);
+ compat_symbol (libc, __ctype32_b, __ctype32_b, GLIBC_2_0);
+ compat_symbol (libc, __ctype32_tolower, __ctype32_tolower, GLIBC_2_2);
+ compat_symbol (libc, __ctype32_toupper, __ctype32_toupper, GLIBC_2_2);
++#endif
+
+ #endif
diff --git a/sys-libs/glibc/files/digest-glibc-2.3.1 b/sys-libs/glibc/files/digest-glibc-2.3.1-r1
index a0effd0be274..a0effd0be274 100644
--- a/sys-libs/glibc/files/digest-glibc-2.3.1
+++ b/sys-libs/glibc/files/digest-glibc-2.3.1-r1
diff --git a/sys-libs/glibc/glibc-2.3.1.ebuild b/sys-libs/glibc/glibc-2.3.1-r1.ebuild
index c3883d473fc1..05e764ec3e9e 100644
--- a/sys-libs/glibc/glibc-2.3.1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1.ebuild,v 1.3 2002/10/24 23:23:45 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r1.ebuild,v 1.1 2002/10/26 00:53:09 azarah Exp $
IUSE="nls pic build"
@@ -79,6 +79,17 @@ src_unpack() {
# This next patch fixes a test that will timeout due to ReiserFS' slow handling of sparse files
einfo "Applying test-lfs-timeout patch..."
cd ${S}/io; patch -p0 < ${FILESDIR}/glibc-2.2.2-test-lfs-timeout.patch > /dev/null || die
+
+ # This add back glibc 2.2 compadibility. See bug #8766 and #9586 for more info,
+ # and also:
+ #
+ # http://lists.debian.org/debian-glibc/2002/debian-glibc-200210/msg00093.html
+ #
+ # We should think about remoing it in the future after things have settled.
+ #
+ # <azarah@gentoo.org> (26 Oct 2002).
+ einfo "Applying ctype-compat patch..."
+ cd ${S}; patch -p1 < ${FILESDIR}/${PV}/${P}-ctype-compat.patch > /dev/null || die
}
src_compile() {