summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-05-31 05:35:36 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-05-31 05:35:36 +0000
commite014d90260401f03de74965078792b9a0fbc17a2 (patch)
tree8b9f59bffdcb9d9f41eee91f5f39540e412ba202 /sys-libs/gpm
parentadded mmx/3dnow optimisation patches (diff)
downloadgentoo-2-e014d90260401f03de74965078792b9a0fbc17a2.tar.gz
gentoo-2-e014d90260401f03de74965078792b9a0fbc17a2.tar.bz2
gentoo-2-e014d90260401f03de74965078792b9a0fbc17a2.zip
updated gpm to r2 trying to fix libsvga bug
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog10
-rw-r--r--sys-libs/gpm/files/digest-gpm-1.20.0-r22
-rw-r--r--sys-libs/gpm/files/gpm.conf.d5
-rw-r--r--sys-libs/gpm/gpm-1.20.0-r2.ebuild66
4 files changed, 80 insertions, 3 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index b52df6b57822..8367238f6f3a 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/gpm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.4 2002/05/26 21:50:47 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.5 2002/05/31 05:35:36 naz Exp $
+
+*gpm-1.20.0-r2 (29 May 2002)
+
+ 29 May 2002; Micahel Nazaroff <naz@gentoo.org> gpm-1.20.0-r2.ebuild :
+
+ Ok with this added patch should take care of the svgalib and ncurses problem
+ hopefully. Moved the ebuild to r2 to update force update from the r1 when it's
+ unmasked.
*gpm-1.19.6 (26 May 2002)
diff --git a/sys-libs/gpm/files/digest-gpm-1.20.0-r2 b/sys-libs/gpm/files/digest-gpm-1.20.0-r2
new file mode 100644
index 000000000000..b1b1ab588359
--- /dev/null
+++ b/sys-libs/gpm/files/digest-gpm-1.20.0-r2
@@ -0,0 +1,2 @@
+MD5 ab33423219cfef97fce158af48d3ad8c gpm-1.20.0.tar.bz2 390987
+MD5 f96c608d93d6b3f69dbe87be43634ca2 gpm-1.20.0-patch.tar.bz2 2137
diff --git a/sys-libs/gpm/files/gpm.conf.d b/sys-libs/gpm/files/gpm.conf.d
index 7fd160d2c8ca..5d7640513f9a 100644
--- a/sys-libs/gpm/files/gpm.conf.d
+++ b/sys-libs/gpm/files/gpm.conf.d
@@ -1,10 +1,11 @@
# Config file for /etc/init.d/gpm
-# The type of mouse you have and the device it is connected to
+# Please uncomment the type of mouse you have and the appropriate MOUSEDEV entry
#MOUSE=ps2
+#MOUSE=imps2
#MOUSEDEV=/dev/psaux
-
+#MOUSEDEV=/dev/input/mice
# Extra settings
diff --git a/sys-libs/gpm/gpm-1.20.0-r2.ebuild b/sys-libs/gpm/gpm-1.20.0-r2.ebuild
new file mode 100644
index 000000000000..e99ebed87f04
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.0-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.0-r2.ebuild,v 1.1 2002/05/31 05:35:36 naz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console-based mouse driver"
+SRC_URI="ftp://arcana.linux.it/pub/gpm/gpm-1.20.0.tar.bz2
+ http://www.ibiblio.org/gentoo/distfiles/gpm-1.20.0-patch.tar.bz2"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ sys-devel/autoconf"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ #this little hack turns off EMACS byte compilation. Really don't want
+ #this thing auto-detecting emacs
+ patch -p1 < ${WORKDIR}/gpm.patch || die
+ env ac_cv_path_emacs=no \
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/gpm || die
+
+ # Do not create gpmdoc.ps, as it cause build to fail with our version
+ # of tetex (it is already there, so this will only create missing
+ # manpages)
+ cp doc/Makefile doc/Makefile.orig
+ sed -e 's:all\: $(srcdir)/gpmdoc.ps:all\::' \
+ doc/Makefile.orig > doc/Makefile
+
+ emake || die
+}
+
+src_install() {
+ if [ ! -e ${S}/mkinstalldirs ]
+ then
+ #create missing script
+ echo 'mkdir -p "$@"' > ${S}/mkinstalldirs
+ chmod u+x ${S}/mkinstalldirs
+ fi
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/gpm \
+ install || die
+ chmod 755 ${D}/usr/lib/libgpm.so.*
+ dodoc BUGS COPYING ChangeLog Changes MANIFEST README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+# doman doc/gpm.8 doc/mev.1 doc/gpm-root.1 doc/gpm-types.7 doc/mouse-test.1
+ doinfo doc/gpm.info
+# docinto txt
+# dodoc doc/gpmdoc.txt
+# docinto ps
+# dodoc doc/gpmdoc.ps
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gpm.rc6 gpm
+ insinto /etc/conf.d
+ newins ${FILESDIR}/gpm.conf.d gpm
+}