summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-07-12 22:19:44 +0000
committerTom Gall <tgall@gentoo.org>2004-07-12 22:19:44 +0000
commit1f456d90b2bd31db6838be9460f613b275d85616 (patch)
treea48838777f389c08019823a74e10e74d38061aba /sys-libs
parentRemoved ancient ebuild. (Manifest recommit) (diff)
downloadgentoo-2-1f456d90b2bd31db6838be9460f613b275d85616.tar.gz
gentoo-2-1f456d90b2bd31db6838be9460f613b275d85616.tar.bz2
gentoo-2-1f456d90b2bd31db6838be9460f613b275d85616.zip
ppc64, ld.so take 2
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040605.ebuild12
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619.ebuild12
3 files changed, 23 insertions, 7 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 47858a0586af..17318a5e2053 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.207 2004/07/12 02:25:12 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.208 2004/07/12 22:19:44 tgall Exp $
+
+ 11 Jul 2004; Tom Gall <tgall@gentoo.org> glibc-2.3.4.20040619.ebuild,
+ glibc-2.3.4.20040605.ebuild:
+ let's try the right section and gussy it up a bit
11 Jul 2004; Tom Gall <tgall@gentoo.org> glibc-2.3.4.20040619.ebuild:
fix bug #56615, ld.so.1 prob on ppc64
diff --git a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
index 15bffcb711f0..fe68b9e19156 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.23 2004/07/12 02:19:43 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.24 2004/07/12 22:19:44 tgall Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -541,8 +541,6 @@ EOF
insinto /etc
doins ${FILESDIR}/locales.build
- use ppc64 && dosym /lib/ld64.so.1 /lib/ld.so.1
-
use makecheck && do_makecheck
}
@@ -569,6 +567,14 @@ pkg_postinst() {
${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
fi
+ if [ ! -e "${ROOT}/ld.so.1" -a "`use ppc64`" ]
+ then
+ pushd ${ROOT}
+ cd ${ROOT}/lib
+ ln -s ld64.so.1 ld.so.1
+ popd
+ fi
+
# Reload init ...
if [ "${ROOT}" = "/" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
index b21f03dd1ebb..15389cb79b6a 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.14 2004/07/12 17:44:46 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.15 2004/07/12 22:19:44 tgall Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -701,8 +701,6 @@ EOF
# Some things want this, notably ash.
dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
- use ppc64 && dosym /lib/ld64.so.1 /lib/ld.so.1
-
# This is our new config file for building locales
insinto /etc
doins ${FILESDIR}/locales.build
@@ -738,6 +736,14 @@ pkg_postinst() {
${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
fi
+ if [ ! -e "${ROOT}/ld.so.1" -a "`use ppc64`" ]
+ then
+ pushd ${ROOT}
+ cd ${ROOT}/lib
+ ln -s ld64.so.1 ld.so.1
+ popd
+ fi
+
# Reload init ...
if [ "${ROOT}" = "/" ]; then
/sbin/init U &> /dev/null