summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-10-13 17:31:46 +0000
committerTravis Tilley <lv@gentoo.org>2004-10-13 17:31:46 +0000
commit517ab47144f1d7bfdad84be4cd503cf5e6b7a782 (patch)
tree37c20b09e73b7a2764dd992d7bd03f5fe19cd9c6 /sys-libs
parent+ quick assuan fix, closing bug #66362 (diff)
downloadgentoo-2-517ab47144f1d7bfdad84be4cd503cf5e6b7a782.tar.gz
gentoo-2-517ab47144f1d7bfdad84be4cd503cf5e6b7a782.tar.bz2
gentoo-2-517ab47144f1d7bfdad84be4cd503cf5e6b7a782.zip
it seems the strange libpthread-not-installed bug was an ebuild quirk and not a portage quirk. it should hopefully be fixed now. i've also added a safety function to 2.3.4.20040808 and 2.3.4.20041006 that will prevent glibc from installing if libpthread is missing, which will likely be expanded further in the future.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog15
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild14
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041006.ebuild14
3 files changed, 31 insertions, 12 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 1fa902eefe2c..0faec323f9f8 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.275 2004/10/13 17:16:12 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.276 2004/10/13 17:31:46 lv Exp $
13 Oct 2004; Guy Martin <gmsoft@gentoo.org> glibc-2.3.4.20040808-r1.ebuild:
Moved Lv's latest patch into do_arch{ia64|amd64}_patches() to avoid breakage
@@ -13,11 +13,16 @@
12 Oct 2004; Guy Martin <gmsoft@gentoo.org> glibc-2.3.4.20040808-r1.ebuild:
Stable on hppa.
+ 13 Oct 2004; Travis Tilley <lv@gentoo.org> glibc-2.3.4.20040808-r1.ebuild,
+ glibc-2.3.4.20041006.ebuild:
+ it seems the strange libpthread-not-installed bug was an ebuild quirk and not
+ a portage quirk. it should hopefully be fixed now. i've also added a safety
+ function to 2.3.4.20040808 and 2.3.4.20041006 that will prevent glibc from
+ installing if libpthread is missing, which will likely be expanded further in
+ the future. re-keyworded 2.3.4.20041006 ~amd64.
+
12 Oct 2004; Travis Tilley <lv@gentoo.org> glibc-2.3.4.20041006.ebuild:
- a portage quirk seems to be installing and then uninstalling libpthread on
- amd64, so i'm re-keywording -amd64 until this is fixed. if you havent snagged
- this bug, you should be safe. if you have nptl in USE, you -should- be able to
- simply emerge glibc twice and portage will stop removing libpthread.
+ keyworded -amd64 for libpthread bug.
11 Oct 2004; <solar@gentoo.org> glibc-2.3.4.20040808-r1.ebuild:
marked 20040808-r1 stable x86 for 2004.3
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 111862fff961..9da45cef8ec2 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.6 2004/10/13 17:16:12 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.7 2004/10/13 17:31:46 lv Exp $
inherit eutils flag-o-matic gcc
@@ -602,9 +602,9 @@ src_install() {
install || die
# now, strip everything but the thread libs #46186
mkdir ${T}/thread-backup
- mv ${D}/lib/lib{pthread,thread_db}* ${T}/thread-backup/
+ mv ${D}/$(get_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
env -uRESTRICT prepallstrip
- mv ${T}/thread-backup/* ${D}/lib/
+ mv ${T}/thread-backup/* ${D}/$(get_libdir)/ || die
# If librt.so is a symlink, change it into linker script (Redhat)
if [ -L "${D}/usr/lib/librt.so" -a "${LIBRT_LINKERSCRIPT}" = "yes" ]; then
@@ -692,6 +692,8 @@ EOF
insinto /etc
doins ${FILESDIR}/locales.build
+ must_exist /$(get_libdir)/ libpthread.so.0
+
# this whole section is useless, it fails if sandbox is LOADED, not if it's
# enabled. but forcing sandbox not to load isnt an option...
if use makecheck; then
@@ -783,3 +785,9 @@ pkg_postinst() {
/sbin/init U &> /dev/null
fi
}
+
+
+must_exist() {
+ test -e ${D}/${1}/${2} || die "${1}/${2} was not installed"
+}
+
diff --git a/sys-libs/glibc/glibc-2.3.4.20041006.ebuild b/sys-libs/glibc/glibc-2.3.4.20041006.ebuild
index 3c8d9790d560..7fe49ed21f0f 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041006.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041006.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041006.ebuild,v 1.4 2004/10/12 04:10:03 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041006.ebuild,v 1.5 2004/10/13 17:31:46 lv Exp $
inherit eutils flag-o-matic gcc
@@ -40,7 +40,7 @@ SRC_URI="http://dev.gentoo.org/~lv/${PN}-${BASE_PV}.tar.bz2
LICENSE="LGPL-2"
SLOT="2.2"
-KEYWORDS="-* ~x86 -amd64 ~hppa ~ppc64 ~ppc"
+KEYWORDS="-* ~x86 ~amd64 ~hppa ~ppc64 ~ppc"
IUSE="nls pic build nptl nptlonly erandom hardened multilib debug userlocales"
RESTRICT="nostrip" # we'll handle stripping ourself #46186
@@ -712,11 +712,11 @@ src_install() {
mkdir -p ${T}/thread-backup
mv ${D}/$(get_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
if use !nptlonly && want_nptl ; then
- mkdir -o ${T}/thread-backup/tls
+ mkdir -p ${T}/thread-backup/tls
mv ${D}/$(get_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
fi
env -uRESTRICT prepallstrip
- cp -R ${T}/thread-backup/* ${D}/lib/
+ cp -R -- ${T}/thread-backup/* ${D}/$(get_libdir)/ || die
# If librt.so is a symlink, change it into linker script (Redhat)
if [ -L "${D}/usr/$(get_libdir)/librt.so" -a "${LIBRT_LINKERSCRIPT}" = "yes" ]; then
@@ -799,6 +799,12 @@ EOF
# This is our new config file for building locales
insinto /etc
doins ${FILESDIR}/locales.build
+
+ must_exist /$(get_libdir)/ libpthread.so.0
+}
+
+must_exist() {
+ test -e ${D}/${1}/${2} || die "${1}/${2} was not installed"
}
fix_lib64_symlinks() {