summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-01-30 20:32:07 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-01-30 20:32:07 +0000
commit5e46622a4b5231dc539b2aa4e52e2ad2b55f2895 (patch)
treecf50da556c73e3d5728bc3389f2a1726c623a373 /sys-libs
parentinitial ebuild (diff)
downloadgentoo-2-5e46622a4b5231dc539b2aa4e52e2ad2b55f2895.tar.gz
gentoo-2-5e46622a4b5231dc539b2aa4e52e2ad2b55f2895.tar.bz2
gentoo-2-5e46622a4b5231dc539b2aa4e52e2ad2b55f2895.zip
Latest version. Of course, the package.mask blocks this version too.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/db-4.0.14.ebuild33
-rw-r--r--sys-libs/db/files/digest-db-4.0.141
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
new file mode 100644
index 000000000000..14ef5736a1e3
--- /dev/null
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.1 2002/01/30 20:32:07 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Berkeley DB"
+
+SRC_URI="http://www.sleepycat.com/update/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ cd dist
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install () {
+ cd dist
+
+ make prefix=${D}/usr install || die
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
+}
diff --git a/sys-libs/db/files/digest-db-4.0.14 b/sys-libs/db/files/digest-db-4.0.14
new file mode 100644
index 000000000000..cb9924c89b80
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.0.14
@@ -0,0 +1 @@
+MD5 12262c64fcd64b772e7cffad8e4d0ebc db-4.0.14.tar.gz 2701799