summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-24 23:52:40 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-24 23:52:40 +0000
commit715697234ab86755a6625c94890cfe237bff30cb (patch)
treed033778ac2955b3e564f10f38249cc7891d43d3d /sys-libs
parentia64 stable (diff)
downloadgentoo-2-715697234ab86755a6625c94890cfe237bff30cb.tar.gz
gentoo-2-715697234ab86755a6625c94890cfe237bff30cb.tar.bz2
gentoo-2-715697234ab86755a6625c94890cfe237bff30cb.zip
Cleanup multilib code to use multilib.eclass stuff over env-vars.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 3748b4010932..0d1f9141eb58 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.39 2005/01/20 15:50:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.40 2005/01/24 23:52:40 eradicator Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -622,10 +622,11 @@ src_unpack() {
src_compile() {
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
local MLTEST=$(type dyn_unpack)
if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ]; then
OABI="${ABI}"
- for ABI in ${MULTILIB_ABIS}; do
+ for ABI in $(get_abi_order); do
export ABI
einfo "Compiling ${ABI} glibc"
src_compile && mv ${WORKDIR}/build ${WORKDIR}/build.${ABI}
@@ -699,10 +700,11 @@ src_test() {
}
src_install() {
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
local MLTEST=$(type dyn_unpack)
if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ]; then
OABI="${ABI}"
- for ABI in ${MULTILIB_ABIS}; do
+ for ABI in $(get_abi_order); do
export ABI
mv ${WORKDIR}/build.${ABI} ${WORKDIR}/build
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index 22dd1f6a8533..a0f6245dd5a5 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.38 2005/01/20 15:50:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.39 2005/01/24 23:52:40 eradicator Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -706,10 +706,11 @@ glibc_do_configure() {
src_compile() {
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
local MLTEST=$(type dyn_unpack)
if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ]; then
OABI="${ABI}"
- for ABI in ${MULTILIB_ABIS}; do
+ for ABI in $(get_abi_order); do
export ABI
einfo "Compiling ${ABI} glibc"
src_compile
@@ -747,10 +748,11 @@ src_test() {
}
src_install() {
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
local MLTEST=$(type dyn_unpack)
if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ]; then
OABI="${ABI}"
- for ABI in ${MULTILIB_ABIS}; do
+ for ABI in $(get_abi_order); do
export ABI
# Handle stupid lib32 BS