summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaarten Thibaut <murphy@gentoo.org>2002-08-16 01:22:43 +0000
committerMaarten Thibaut <murphy@gentoo.org>2002-08-16 01:22:43 +0000
commit72cf231408be4e8fbda85002ed7ff23faccd05c6 (patch)
tree57d6dec9e03f66b90272d2234867d9358d161fee /sys-libs
parent- Initial version of the ebuild. (diff)
downloadgentoo-2-72cf231408be4e8fbda85002ed7ff23faccd05c6.tar.gz
gentoo-2-72cf231408be4e8fbda85002ed7ff23faccd05c6.tar.bz2
gentoo-2-72cf231408be4e8fbda85002ed7ff23faccd05c6.zip
Adding sparc patch for compilation by gcc 3.1.1
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/glibc-2.2.5-gcc311-sparc.patch21
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r5.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r6.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r7.ebuild7
4 files changed, 41 insertions, 3 deletions
diff --git a/sys-libs/glibc/files/glibc-2.2.5-gcc311-sparc.patch b/sys-libs/glibc/files/glibc-2.2.5-gcc311-sparc.patch
new file mode 100644
index 000000000000..9da89e75d89c
--- /dev/null
+++ b/sys-libs/glibc/files/glibc-2.2.5-gcc311-sparc.patch
@@ -0,0 +1,21 @@
+--- glibc-2.2.5/sysdeps/unix/sysv/sysv4/solaris2/sparc/sysdep.h.old Fri Jul 6 06:56:22 2001
++++ glibc-2.2.5/sysdeps/unix/sysv/sysv4/solaris2/sparc/sysdep.h Wed Jul 24 14:36:31 2002
+@@ -51,6 +51,6 @@
+ #define r1 %o1
+ #define MOVE(x,y) mov x, y
+
+-#define LOC(name) .##L##name
++#define LOC(name) .L##name
+
+ #endif /* __ASSEMBLER__ */
+--- glibc-2.2.5/sysdeps/unix/sysv/linux/sparc/sparc32/sysdep.h.old Fri Jul 6 06:56:21 2001
++++ glibc-2.2.5/sysdeps/unix/sysv/linux/sparc/sparc32/sysdep.h Wed Jul 24 14:35:08 2002
+@@ -48,7 +48,7 @@
+ #define END(name) \
+ .size name, . - name
+
+-#define LOC(name) . ## L ## name
++#define LOC(name) .L##name
+
+ #ifdef PIC
+ #define SYSCALL_ERROR_HANDLER \
diff --git a/sys-libs/glibc/glibc-2.2.5-r5.ebuild b/sys-libs/glibc/glibc-2.2.5-r5.ebuild
index 900370ccb240..8da8acea0855 100644
--- a/sys-libs/glibc/glibc-2.2.5-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r5.ebuild,v 1.6 2002/08/14 03:06:54 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r5.ebuild,v 1.7 2002/08/16 01:22:43 murphy Exp $
inherit flag-o-matic
filter-flags "-fomit-frame-pointer -malign-double"
@@ -93,6 +93,12 @@ src_unpack() {
# problems with gcc-3.1.1.
# (Azarah, 14 Jul 2002)
patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311.patch || die
+
+ # Avoid "Error: illegal instruction" when compiling on sparc with gcc 3.1.1
+ if [ ${ARCH} == "sparc" -o ${ARCH} == "sparc64" ]; then
+ patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311-sparc.patch || die
+ fi
+
}
src_compile() {
diff --git a/sys-libs/glibc/glibc-2.2.5-r6.ebuild b/sys-libs/glibc/glibc-2.2.5-r6.ebuild
index cc6bded692f1..767104bc87c8 100644
--- a/sys-libs/glibc/glibc-2.2.5-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r6.ebuild,v 1.2 2002/08/14 03:06:54 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r6.ebuild,v 1.3 2002/08/16 01:22:43 murphy Exp $
inherit flag-o-matic
filter-flags "-fomit-frame-pointer -malign-double"
@@ -98,6 +98,12 @@ src_unpack() {
# problems with gcc-3.1.1.
# (Azarah, 14 Jul 2002)
patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311.patch || die
+
+ # Avoid "Error: illegal instruction" when compiling on sparc with gcc 3.1.1
+ if [ ${ARCH} == "sparc" -o ${ARCH} == "sparc64" ]; then
+ patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311-sparc.patch || die
+ fi
+
}
src_compile() {
diff --git a/sys-libs/glibc/glibc-2.2.5-r7.ebuild b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
index a87477ede2b4..4bcd24a579aa 100644
--- a/sys-libs/glibc/glibc-2.2.5-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.3 2002/08/15 06:03:58 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.4 2002/08/16 01:22:43 murphy Exp $
inherit flag-o-matic
filter-flags "-fomit-frame-pointer -malign-double"
@@ -107,6 +107,11 @@ src_unpack() {
# problems with gcc-3.1.1.
# (Azarah, 14 Jul 2002)
cd ${S}; patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311.patch || die
+
+ # Avoid "Error: illegal instruction" when compiling on sparc with gcc 3.1.1
+ if [ ${ARCH} == "sparc" -o ${ARCH} == "sparc64" ]; then
+ patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311-sparc.patch || die
+ fi
}
src_compile() {