summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-09-02 08:44:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-09-02 08:44:43 +0000
commita8a0026817b853460da682f9aa868e65e4b23a79 (patch)
treebccec7157c283d3767ab42069cb6ab3dfa426c21 /sys-libs
parentadd some more symlink stuff to db_fix_so in the eclass, and remove the old br... (diff)
downloadgentoo-2-a8a0026817b853460da682f9aa868e65e4b23a79.tar.gz
gentoo-2-a8a0026817b853460da682f9aa868e65e4b23a79.tar.bz2
gentoo-2-a8a0026817b853460da682f9aa868e65e4b23a79.zip
add some more symlink stuff to db_fix_so in the eclass, and remove the old broken leftover parts from ebuild
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog8
-rw-r--r--sys-libs/db/Manifest4
-rw-r--r--sys-libs/db/db-3.2.9-r9.ebuild142
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r91
4 files changed, 152 insertions, 3 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 679dd0e1fdd5..6b497138485c 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.41 2003/08/21 11:08:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.42 2003/09/02 08:44:41 robbat2 Exp $
+
+*db-3.2.9-r9 (02 Sep 2003)
+
+ 02 Sep 2003; Robin H. Johnson <robbat2@gentoo.org> db-3.2.9-r9.ebuild:
+ add some more symlink stuff to db_fix_so in the eclass, and remove the old
+ broken leftover parts from ebuild
*db-4.1.25_p1-r1 (21 Aug 2003)
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index 4113859b935e..8c47a15c604f 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -9,8 +9,8 @@ MD5 3fa2f9737e2c0ac4230fd12f3c8b54a5 db-3.2.9-r7.ebuild 4370
MD5 09ddb16abbd409d87e899893d698dff3 db-3.2.9-r2.ebuild 3221
MD5 01e9f1d4c2c9ac3dd639d98bd03c768c db-4.1.25.ebuild 2259
MD5 6f3169cda6bac26f0aaa65dd76331c76 db-4.0.14.ebuild 2386
-MD5 3c3825495a8e1fd3477d7f3b87fca63e db-3.2.9-r9.ebuild 3533
-MD5 79300e270ae3e29b30ed3706832980ee ChangeLog 8439
+MD5 1dc382bd80bc8ff0298961f73ed2345d db-3.2.9-r9.ebuild 3516
+MD5 2ff7cea5a343406d88381685744c4b76 ChangeLog 8463
MD5 5c921197970cd970a8fbb4cad2d7df7b metadata.xml 1457
MD5 e6fb267b86831c5399fe6bb12b062481 db-4.0.14-r1.ebuild 2706
MD5 eb9b0f2c1d8440c6c49fc1d916c2dc0e files/db-4.0.14-fix-dep-link.patch 1119
diff --git a/sys-libs/db/db-3.2.9-r9.ebuild b/sys-libs/db/db-3.2.9-r9.ebuild
new file mode 100644
index 000000000000..f9e1634a2eb8
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r9.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r9.ebuild,v 1.1 2003/09/02 08:44:41 robbat2 Exp $
+
+IUSE="doc"
+
+inherit libtool
+inherit eutils
+inherit db
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com/"
+
+SLOT="3"
+LICENSE="DB"
+# This ebuild is to be the compatibility ebuild for when db4 is put
+# in the tree.
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+# We need m4 too else build fails without config.guess
+
+# This doesn't build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+src_unpack() {
+ unpack ${A}
+
+ chmod -R ug+w *
+
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/patch.3.2.9.1
+ epatch ${FILESDIR}/patch.3.2.9.2
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/${P}-fix-dep-link.patch
+
+ # We should get dump185 to link against system db1 ..
+ # <azarah@gentoo.org> (23 Feb 2003)
+ mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
+ -e 's:DB185LIB=:DB185LIB= -ldb1:' \
+ ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
+
+ # Fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+ sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
+}
+
+src_compile() {
+ local conf=
+
+ conf="--host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cxx \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr"
+ # --enable-rpc aparently does not work .. should verify this
+ # at some stage ...
+
+ # NOTE: we should not build both shared and static versions
+ # of the libraries in the same build root!
+
+ einfo "Configuring ${P} (static)..."
+ mkdir -p ${S}/build-static
+ cd ${S}/build-static
+ ../dist/configure ${conf} \
+ --enable-static || die
+
+ einfo "Configuring ${P} (shared)..."
+ mkdir -p ${S}/build-shared
+ cd ${S}/build-shared
+ ../dist/configure ${conf} \
+ --enable-shared || die
+
+ # Parallel make does not work
+ MAKEOPTS="${MAKEOPTS} -j1"
+ einfo "Building ${P} (static)..."
+ cd ${S}/build-static
+ emake || die "Static build failed"
+ einfo "Building ${P} (shared)..."
+ cd ${S}/build-shared
+ emake || die "Shared build failed"
+}
+
+src_install () {
+ cd ${S}/build-shared
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ install || die
+
+ cd ${S}/build-static
+ cp libdb.a libdb-3.2.a
+ cp libdb_cxx.a libdb_cxx-3.2.a
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+
+ db_src_install_headerslot
+
+ # this is now done in the db eclass, function db_fix_so and db_src_install_usrlibcleanup
+ #cd ${D}/usr/lib
+ #ln -s libdb-3.2.so libdb.so.3
+
+ # For some reason, db.so's are *not* readable by group or others,
+ # resulting in no one but root being able to use them!!!
+ # This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ # The .la's aren't readable either
+ chmod go+r *.la
+
+ cd ${S}
+ dodoc README LICENSE
+
+ db_src_install_doc
+
+ db_src_install_usrbinslot
+
+ db_src_install_usrlibcleanup
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
+
diff --git a/sys-libs/db/files/digest-db-3.2.9-r9 b/sys-libs/db/files/digest-db-3.2.9-r9
new file mode 100644
index 000000000000..cc0f167ea09b
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r9
@@ -0,0 +1 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238