summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-31 18:02:24 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-31 18:02:24 +0000
commitc5fcab51dd2cdbd81a144701844c42f6e8f93b73 (patch)
treeae01038cbcd610aca72d77e985ad9893ef422e31 /sys-libs
parentinitial ebuild (diff)
downloadgentoo-2-c5fcab51dd2cdbd81a144701844c42f6e8f93b73.tar.gz
gentoo-2-c5fcab51dd2cdbd81a144701844c42f6e8f93b73.tar.bz2
gentoo-2-c5fcab51dd2cdbd81a144701844c42f6e8f93b73.zip
add libc_wait to 2.3.1
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog12
-rw-r--r--sys-libs/glibc/files/2.3.1/glibc-2.3.1-libc_wait-compat.patch26
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r1.ebuild15
3 files changed, 51 insertions, 2 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index f7967c28de98..69779e00226b 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.23 2002/10/30 02:44:58 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.24 2002/10/31 18:02:24 azarah Exp $
+
+ 30 Oct 2002; Martin Schlemmer <azarah@gentoo.org> glibc-2.3.1-r1.ebuild :
+
+ One more compat issue which breaks sun-jdk-1.3.1. See bug #8766 for more
+ info, and also:
+
+ http://sources.redhat.com/ml/libc-alpha/2002-04/msg00143.html
+
+ Thanks to Jan Gutter <jangutter@tuks.co.za> for reporting it. Added
+ libc_wait-compat.patch as fix.
*glibc-2.3.1-r1 (26 Oct 2002)
diff --git a/sys-libs/glibc/files/2.3.1/glibc-2.3.1-libc_wait-compat.patch b/sys-libs/glibc/files/2.3.1/glibc-2.3.1-libc_wait-compat.patch
new file mode 100644
index 000000000000..db4bfe27f861
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.1/glibc-2.3.1-libc_wait-compat.patch
@@ -0,0 +1,26 @@
+2002-04-19 Bruno Haible <bruno@clisp.org>
+
+ * posix/Versions: Move back __libc_wait to GLIBC_2.0 section.
+
+--- glibc-20020408/posix/Versions.bak 2002-02-04 12:42:40.000000000 +0100
++++ glibc-20020408/posix/Versions 2002-04-19 01:01:00.000000000 +0200
+@@ -14,6 +14,9 @@
+ # functions used by libstdc++ 2.7.2
+ __waitpid;
+
++ # functions used by SunJava2-1.3.1/jre/lib/i386/libjava.so
++ __libc_wait;
++
+ # global variables
+ __environ; _environ;
+
+@@ -108,7 +111,7 @@
+ GLIBC_PRIVATE {
+ # functions which have an additional interface since they are
+ # are cancelable.
+- __libc_wait; __libc_waitpid; __libc_pause; __libc_nanosleep; __libc_fork;
++ __libc_waitpid; __libc_pause; __libc_nanosleep; __libc_fork;
+ __libc_pread; __libc_pread64; __libc_pwrite; __libc_pwrite64;
+ }
+ }
+
diff --git a/sys-libs/glibc/glibc-2.3.1-r1.ebuild b/sys-libs/glibc/glibc-2.3.1-r1.ebuild
index 05e764ec3e9e..d3334c5165e4 100644
--- a/sys-libs/glibc/glibc-2.3.1-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r1.ebuild,v 1.1 2002/10/26 00:53:09 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r1.ebuild,v 1.2 2002/10/31 18:02:24 azarah Exp $
IUSE="nls pic build"
@@ -87,9 +87,22 @@ src_unpack() {
#
# We should think about remoing it in the future after things have settled.
#
+ # Thanks to Jan Gutter <jangutter@tuks.co.za> for reporting it.
+ #
# <azarah@gentoo.org> (26 Oct 2002).
einfo "Applying ctype-compat patch..."
cd ${S}; patch -p1 < ${FILESDIR}/${PV}/${P}-ctype-compat.patch > /dev/null || die
+
+ # One more compat issue which breaks sun-jdk-1.3.1. See bug #8766 for more
+ # info, and also:
+ #
+ # http://sources.redhat.com/ml/libc-alpha/2002-04/msg00143.html
+ #
+ # Thanks to Jan Gutter <jangutter@tuks.co.za> for reporting it.
+ #
+ # <azarah@gentoo.org> (30 Oct 2002).
+ einfo "Applying libc_wait-compat patch..."
+ cd ${S}; patch -p1 < ${FILESDIR}/${PV}/${P}-libc_wait-compat.patch > /dev/null || die
}
src_compile() {