summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-25 03:06:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-25 03:06:09 +0000
commitcd176c20853149dd33ec3285fbb38aada590fbca (patch)
tree893ce9129686ce51cd250a579ea526e921f39c21 /sys-process/procps
parentVersion bump. (diff)
downloadgentoo-2-cd176c20853149dd33ec3285fbb38aada590fbca.tar.gz
gentoo-2-cd176c20853149dd33ec3285fbb38aada590fbca.tar.bz2
gentoo-2-cd176c20853149dd33ec3285fbb38aada590fbca.zip
Bug #279819: make top not ignore .toprc.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/procps')
-rw-r--r--sys-process/procps/ChangeLog10
-rw-r--r--sys-process/procps/files/procps-3.2.8-toprc-fixup.patch16
-rw-r--r--sys-process/procps/procps-3.2.8-r1.ebuild85
3 files changed, 109 insertions, 2 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index 3ec2b4cf56b1..21443ec7d61d 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/procps
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.38 2009/11/23 04:56:23 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.39 2010/01/25 03:06:08 robbat2 Exp $
+
+*procps-3.2.8-r1 (25 Jan 2010)
+
+ 25 Jan 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +procps-3.2.8-r1.ebuild, +files/procps-3.2.8-toprc-fixup.patch:
+ Bug #279819: make top not ignore .toprc.
23 Nov 2009; Mike Frysinger <vapier@gentoo.org> procps-3.2.8.ebuild:
Add USE=unicode to control multibyte code.
diff --git a/sys-process/procps/files/procps-3.2.8-toprc-fixup.patch b/sys-process/procps/files/procps-3.2.8-toprc-fixup.patch
new file mode 100644
index 000000000000..24890b0d1369
--- /dev/null
+++ b/sys-process/procps/files/procps-3.2.8-toprc-fixup.patch
@@ -0,0 +1,16 @@
+X-Gentoo-Bug: 279819
+Upstream-Patch: http://procps.cvs.sourceforge.net/viewvc/procps/procps/top.c?r1=1.132&r2=1.134
+--- top.c 2008/03/24 04:41:26 1.132
++++ top.c 2009/12/10 11:37:48 1.134
+@@ -2190,7 +2190,10 @@
+ // Value a window's name and make the associated group name.
+ static void win_names (WIN_t *q, const char *name)
+ {
+- sprintf(q->rc.winname, "%.*s", WINNAMSIZ -1, name);
++ // Note that src==dst is illegal in sprintf.
++ // Failure: amd64, glibc 2.9-20081201, gcc 4.3.4
++ if(q->rc.winname != name)
++ sprintf(q->rc.winname, "%.*s", WINNAMSIZ -1, name);
+ sprintf(q->grpname, "%d:%.*s", q->winnum, WINNAMSIZ -1, name);
+ }
+
diff --git a/sys-process/procps/procps-3.2.8-r1.ebuild b/sys-process/procps/procps-3.2.8-r1.ebuild
new file mode 100644
index 000000000000..a8f02945953e
--- /dev/null
+++ b/sys-process/procps/procps-3.2.8-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.2.8-r1.ebuild,v 1.1 2010/01/25 03:06:08 robbat2 Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="Standard informational utilities and process-handling tools"
+HOMEPAGE="http://procps.sourceforge.net/"
+SRC_URI="http://procps.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="n32 unicode"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/3.2.5-top-sort.patch
+ epatch "${FILESDIR}"/procps-3.2.7-proc-mount.patch
+ epatch "${FILESDIR}"/procps-3.2.3-noproc.patch
+ epatch "${FILESDIR}"/procps-3.2.8-toprc-fixup.patch
+
+ # Clean up the makefile
+ # - we do stripping ourselves
+ # - punt fugly gcc flags
+ sed -i \
+ -e '/install/s: --strip : :' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-fweb,)/d' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-Wstrict-aliasing=2,)/s,=2,,' \
+ -e "/^lib64/s:=.*:=$(get_libdir):" \
+ -e 's:-m64::g' \
+ Makefile || die "sed Makefile"
+
+ # mips 2.4.23 headers (and 2.6.x) don't allow PAGE_SIZE to be defined in
+ # userspace anymore, so this patch instructs procps to get the
+ # value from sysconf().
+ epatch "${FILESDIR}"/${PN}-mips-define-pagesize.patch
+
+ # lame unicode stuff checks glibc defines
+ sed -i "s:__GNU_LIBRARY__ >= 6:0 == $(use unicode; echo $?):" proc/escape.c || die
+
+ # n32 isn't completly reliable of an ABI on mips64 at the current
+ # time. Eventually, it will be, but for now, we need to make sure
+ # procps doesn't try to force it on us.
+ if ! use n32 ; then
+ epatch "${FILESDIR}"/${PN}-3.2.6-mips-n32_isnt_usable_on_mips64_yet.patch
+ fi
+}
+
+src_compile() {
+ replace-flags -O3 -O2
+ emake \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ emake \
+ ln_f="ln -sf" \
+ ldconfig="true" \
+ DESTDIR="${D}" \
+ install \
+ || die "install failed"
+
+ insinto /usr/include/proc
+ doins proc/*.h || die "doins include"
+
+ dodoc sysctl.conf BUGS NEWS TODO ps/HACKING
+
+ # compat symlink so people who shouldnt be using libproc can #170077
+ dosym libproc-${PV}.so /$(get_libdir)/libproc.so
+}
+
+pkg_postinst() {
+ einfo "NOTE: With NPTL \"ps\" and \"top\" no longer"
+ einfo "show threads. You can use any of: -m m -L -T H"
+ einfo "in ps or the H key in top to show them"
+}