summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2007-08-16 13:44:15 +0000
committerChristoph Mende <angelos@gentoo.org>2007-08-16 13:44:15 +0000
commit49d2596e42fed54c60e94cae2720413d8607c61f (patch)
tree9cd220b8ee4ff401f7eb4180c5a588c9a72e764e /sys-process
parentinitial ebuild, thanks to M.Fetka ( proxied Maintainer ) on bug #187099 (diff)
downloadgentoo-2-49d2596e42fed54c60e94cae2720413d8607c61f.tar.gz
gentoo-2-49d2596e42fed54c60e94cae2720413d8607c61f.tar.bz2
gentoo-2-49d2596e42fed54c60e94cae2720413d8607c61f.zip
Added a note that linprocfs needs to be mounted on FreeBSD
(Portage version: 2.1.3.6)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog5
-rw-r--r--sys-process/htop/htop-0.6.6.ebuild12
2 files changed, 15 insertions, 2 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 323e6a2f18f3..53467ec15604 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/htop
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.46 2007/08/13 21:59:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.47 2007/08/16 13:44:15 angelos Exp $
+
+ 16 Aug 2007; Christoph Mende <angelos@gentoo.org> htop-0.6.6.ebuild:
+ Added a note that linprocfs needs to be mounted on FreeBSD
13 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org> htop-0.6.6.ebuild:
ppc. stable
diff --git a/sys-process/htop/htop-0.6.6.ebuild b/sys-process/htop/htop-0.6.6.ebuild
index 38ecb1cf98b4..a4fb2ee5365a 100644
--- a/sys-process/htop/htop-0.6.6.ebuild
+++ b/sys-process/htop/htop-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.6.6.ebuild,v 1.7 2007/08/13 21:59:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.6.6.ebuild,v 1.8 2007/08/16 13:44:15 angelos Exp $
inherit flag-o-matic
@@ -13,6 +13,16 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
DEPEND="sys-libs/ncurses"
+pkg_setup() {
+ if use elibc_FreeBSD ; then
+ elog
+ elog "htop needs /proc mounted to work, to mount it type"
+ elog "mount -t linprocfs none /proc"
+ elog "or uncomment the example in /etc/fstab"
+ elog
+ fi
+}
+
src_compile() {
useq debug && append-flags -O -ggdb -DDEBUG
econf || die "configure failed"