summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-16 15:21:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-16 15:21:13 +0000
commit74523c30fb00f4310ea174e4e163e9841c80bd5e (patch)
tree30b5b3d21f96264d4f17e8ca79c90f511a815c78 /sys-process
parentAdd prefix keywords as tested in the prefix overlay, add EPREFIX to configure (diff)
downloadgentoo-2-74523c30fb00f4310ea174e4e163e9841c80bd5e.tar.gz
gentoo-2-74523c30fb00f4310ea174e4e163e9841c80bd5e.tar.bz2
gentoo-2-74523c30fb00f4310ea174e4e163e9841c80bd5e.zip
Fix gid/uid mistake in fcrontab. Thanks to Moshe Kamenksy in bug #309325.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/ChangeLog9
-rw-r--r--sys-process/fcron/fcron-3.0.5-r2.ebuild (renamed from sys-process/fcron/fcron-3.0.5-r1.ebuild)4
-rw-r--r--sys-process/fcron/files/fcron-3.0.5-gentoo.patch (renamed from sys-process/fcron/files/fcron-3.0.5-pam.patch)9
3 files changed, 19 insertions, 3 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index 506adcb9928c..b333b1c62c81 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/fcron
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.71 2010/03/11 13:17:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.72 2010/03/16 15:21:12 flameeyes Exp $
+
+*fcron-3.0.5-r2 (16 Mar 2010)
+
+ 16 Mar 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -fcron-3.0.5-r1.ebuild, +fcron-3.0.5-r2.ebuild,
+ +files/fcron-3.0.5-gentoo.patch, -files/fcron-3.0.5-pam.patch:
+ Fix gid/uid mistake in fcrontab. Thanks to Moshe Kamenksy in bug #309325.
*fcron-3.0.5-r1 (11 Mar 2010)
diff --git a/sys-process/fcron/fcron-3.0.5-r1.ebuild b/sys-process/fcron/fcron-3.0.5-r2.ebuild
index 3b005dab3710..e9b1ebbd4f55 100644
--- a/sys-process/fcron/fcron-3.0.5-r1.ebuild
+++ b/sys-process/fcron/fcron-3.0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.5-r1.ebuild,v 1.1 2010/03/11 13:17:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.5-r2.ebuild,v 1.1 2010/03/16 15:21:12 flameeyes Exp $
inherit cron pam eutils
@@ -42,7 +42,7 @@ src_unpack() {
epatch "${FILESDIR}"/check_system_crontabs.fcron-config-file.patch
# bug #308799
- epatch "${FILESDIR}"/${P}-pam.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
# the script contains bashism, so until upstream fixes it we're
# going to simply require bash for this to work, sorry!
diff --git a/sys-process/fcron/files/fcron-3.0.5-pam.patch b/sys-process/fcron/files/fcron-3.0.5-gentoo.patch
index 25ccbb5bb8f3..bb9fbf01958c 100644
--- a/sys-process/fcron/files/fcron-3.0.5-pam.patch
+++ b/sys-process/fcron/files/fcron-3.0.5-gentoo.patch
@@ -2,6 +2,15 @@ Index: fcron-3.0.5/fcrontab.c
===================================================================
--- fcron-3.0.5.orig/fcrontab.c
+++ fcron-3.0.5/fcrontab.c
+@@ -391,7 +391,7 @@ list_file(char *file)
+
+ explain("listing %s's fcrontab", user);
+
+- fd = open_as_user(file, useruid, fcrontab_uid, O_RDONLY);
++ fd = open_as_user(file, useruid, fcrontab_gid, O_RDONLY);
+ if ( fd < 0 ) {
+ if ( errno == ENOENT ) {
+ explain("user %s has no fcrontab.", user);
@@ -1038,8 +1038,8 @@ main(int argc, char **argv)
/* Open PAM session for the user and obtain any security
credentials we might need */