summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-09-15 08:35:46 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-09-15 08:35:46 +0000
commit50c4ff4ac2824ca5b391115689388edc3e6dafe2 (patch)
tree09f70c99b17736c4cb637d41beaa240280bd4958 /www-apache
parentppc stable, bug #189690 (diff)
downloadgentoo-2-50c4ff4ac2824ca5b391115689388edc3e6dafe2.tar.gz
gentoo-2-50c4ff4ac2824ca5b391115689388edc3e6dafe2.tar.bz2
gentoo-2-50c4ff4ac2824ca5b391115689388edc3e6dafe2.zip
fix apache 2.0/2.2 dependencies
(Portage version: 2.1.3.7)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_mysql/ChangeLog6
-rw-r--r--www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild22
-rw-r--r--www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild22
3 files changed, 11 insertions, 39 deletions
diff --git a/www-apache/mod_auth_mysql/ChangeLog b/www-apache/mod_auth_mysql/ChangeLog
index 40c8cbba3d03..41dd5f4d5b09 100644
--- a/www-apache/mod_auth_mysql/ChangeLog
+++ b/www-apache/mod_auth_mysql/ChangeLog
@@ -1,12 +1,16 @@
# ChangeLog for www-apache/mod_auth_mysql
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/ChangeLog,v 1.3 2007/09/06 17:27:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/ChangeLog,v 1.4 2007/09/15 08:35:46 hollow Exp $
07 Dec 2006; Luca Longinotti <chtekk@gentoo.org>
-files/12_mod_auth_mysql.conf, -files/mod_auth_mysql.patch, metadata.xml,
-mod_auth_mysql-3.0.0.ebuild, mod_auth_mysql-3.0.0-r1.ebuild:
Ebuild cleanup, set mysql as herd too.
+ 15 Sep 2007; Benedikt Böhm <hollow@gentoo.org>
+ mod_auth_mysql-3.0.0-r1.ebuild, mod_auth_mysql-3.0.0-r2.ebuild:
+ fix apache 2.0/2.2 dependencies
+
06 Sep 2007; Raúl Porcel <armin76@gentoo.org>
mod_auth_mysql-3.0.0-r2.ebuild:
x86 stable, as requested by phreak
diff --git a/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild
index 8bee26823b21..334ea53d633b 100644
--- a/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild
+++ b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild,v 1.1 2007/07/29 15:56:00 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild,v 1.2 2007/09/15 08:35:46 hollow Exp $
inherit apache-module
@@ -17,26 +17,10 @@ DEPEND="virtual/mysql
sys-libs/zlib"
RDEPEND="${DEPEND}"
-APXS1_ARGS="-DENABLE=0 -c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE1_MOD_CONF="12_mod_auth_mysql"
-APACHE1_MOD_DEFINE="AUTH_MYSQL"
-
APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE2_MOD_CONF="12_mod_auth_mysql"
+APACHE2_MOD_CONF="12_${PN}"
APACHE2_MOD_DEFINE="AUTH_MYSQL"
DOCFILES="README"
-need_apache
-
-pkg_postinst() {
- if ! useq apache2 ; then
- elog "With regard to bug #132391 the behaviour of ${PN}"
- elog "has changed for Apache-1.3.XX."
- elog
- elog "You now need to enable ${PN} in your .htaccess"
- elog "files explicitely using:"
- elog
- elog " AuthMySQLEnable On"
- fi
-}
+need_apache2_0
diff --git a/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild
index 96a39be265e8..285dc261cdcb 100644
--- a/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild
+++ b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild,v 1.2 2007/09/06 17:27:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild,v 1.3 2007/09/15 08:35:46 hollow Exp $
inherit apache-module eutils
@@ -17,32 +17,16 @@ DEPEND="virtual/mysql
sys-libs/zlib"
RDEPEND="${DEPEND}"
-APXS1_ARGS="-DENABLE=0 -c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE1_MOD_CONF="12_mod_auth_mysql"
-APACHE1_MOD_DEFINE="AUTH_MYSQL"
-
APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE2_MOD_CONF="12_mod_auth_mysql"
+APACHE2_MOD_CONF="12_${PN}"
APACHE2_MOD_DEFINE="AUTH_MYSQL"
DOCFILES="README"
-need_apache
+need_apache2_2
src_unpack() {
unpack ${A}
EPATCH_OPTS="-d ${S} -p1" epatch "${FILESDIR}/${P}-apache-2.2.patch"
EPATCH_OPTS="-d ${S} -p1" epatch "${FILESDIR}/${P}-htpasswd2-auth-style.patch"
}
-
-pkg_postinst() {
- if ! useq apache2 ; then
- elog "With regard to bug #132391 the behaviour of ${PN}"
- elog "has changed for Apache-1.3.XX."
- elog
- elog "You now need to enable ${PN} in your .htaccess"
- elog "files explicitely using:"
- elog
- elog " AuthMySQLEnable On"
- fi
-}