summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-08-16 20:24:15 +0000
committerDon Seiler <rizzo@gentoo.org>2004-08-16 20:24:15 +0000
commitdde88f837f7da74d1752b1f5ba13628aa43ccbbc (patch)
tree402dd22937deac1083548af2bc6713792c3a3940 /www-apps
parentNew ebuild and version with GPG fixes. (Manifest recommit) (diff)
downloadgentoo-2-dde88f837f7da74d1752b1f5ba13628aa43ccbbc.tar.gz
gentoo-2-dde88f837f7da74d1752b1f5ba13628aa43ccbbc.tar.bz2
gentoo-2-dde88f837f7da74d1752b1f5ba13628aa43ccbbc.zip
Version bump and webapp eclassiness
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpwebsite/ChangeLog8
-rw-r--r--www-apps/phpwebsite/Manifest7
-rw-r--r--www-apps/phpwebsite/files/digest-phpwebsite-0.9.3_p41
-rw-r--r--www-apps/phpwebsite/files/postinstall-en.txt17
-rw-r--r--www-apps/phpwebsite/phpwebsite-0.9.3_p4.ebuild43
5 files changed, 73 insertions, 3 deletions
diff --git a/www-apps/phpwebsite/ChangeLog b/www-apps/phpwebsite/ChangeLog
index 5528d31ec36b..c47912ba0d8d 100644
--- a/www-apps/phpwebsite/ChangeLog
+++ b/www-apps/phpwebsite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/phpwebsite
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/ChangeLog,v 1.1 2004/08/15 15:32:57 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/ChangeLog,v 1.2 2004/08/16 20:24:15 rizzo Exp $
+
+*phpwebsite-0.9.3_p4 (16 Aug 2004)
+
+ 16 Aug 2004; Don Seiler <rizzo@gentoo.org> +files/postinstall-en.txt,
+ +phpwebsite-0.9.3_p4.ebuild:
+ Version bump, now with webapp eclass
*phpwebsite-0.9.3_p2-r1 (15 Aug 2004)
diff --git a/www-apps/phpwebsite/Manifest b/www-apps/phpwebsite/Manifest
index 90d08557be12..20bc9e18f9d5 100644
--- a/www-apps/phpwebsite/Manifest
+++ b/www-apps/phpwebsite/Manifest
@@ -1,4 +1,7 @@
-MD5 e3fec57aa99eba955f5c444a83489f71 phpwebsite-0.9.3_p2-r1.ebuild 2078
-MD5 730ab2a968cc98e00364816d37d9a1d7 ChangeLog 2456
+MD5 e145700a334682459d16ede8bbd25fee ChangeLog 2649
MD5 ecbb5a02001856289bc050635b8d8394 metadata.xml 522
+MD5 1fc378eea0778b4e3334a18b9b4a1600 phpwebsite-0.9.3_p2-r1.ebuild 2077
+MD5 fc97c2873a073ca95153ab2af8fd25da phpwebsite-0.9.3_p4.ebuild 1019
MD5 5d0bf869aca158f5d35948955a1aafee files/digest-phpwebsite-0.9.3_p2-r1 136
+MD5 531d74852ee86f3477eeb6e367130d38 files/postinstall-en.txt 442
+MD5 cbb574082a549fde32938920af3bcd19 files/digest-phpwebsite-0.9.3_p4 76
diff --git a/www-apps/phpwebsite/files/digest-phpwebsite-0.9.3_p4 b/www-apps/phpwebsite/files/digest-phpwebsite-0.9.3_p4
new file mode 100644
index 000000000000..25fe93de699e
--- /dev/null
+++ b/www-apps/phpwebsite/files/digest-phpwebsite-0.9.3_p4
@@ -0,0 +1 @@
+MD5 c62490073f780aa8f0ed050ac06cb831 phpwebsite-0.9.3-4-full.tar.gz 3556756
diff --git a/www-apps/phpwebsite/files/postinstall-en.txt b/www-apps/phpwebsite/files/postinstall-en.txt
new file mode 100644
index 000000000000..e8293275bb3e
--- /dev/null
+++ b/www-apps/phpwebsite/files/postinstall-en.txt
@@ -0,0 +1,17 @@
+phpWebSite is installed.
+
+You will need to create a database for phpWebSite
+on your own before starting setup.
+
+Then change permissions for set with this script:
+
+cd ${MY_HTDOCSDIR}/phpwebsite/setup
+./secure_setup.sh setup
+
+Once you have a database ready proceed to
+http://$HOSTNAME/phpwebsite to continue installation.
+
+Once you are done with installation you need to run:
+
+cd ${MY_HTDOCSDIR}/phpwebsite/setup
+./secure_phpws.sh run apache users
diff --git a/www-apps/phpwebsite/phpwebsite-0.9.3_p4.ebuild b/www-apps/phpwebsite/phpwebsite-0.9.3_p4.ebuild
new file mode 100644
index 000000000000..9566425f338a
--- /dev/null
+++ b/www-apps/phpwebsite/phpwebsite-0.9.3_p4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/phpwebsite-0.9.3_p4.ebuild,v 1.1 2004/08/16 20:24:15 rizzo Exp $
+
+inherit webapp
+
+MY_PV="${PV/_p/-}"
+DESCRIPTION="phpWebSite Content Management System"
+HOMEPAGE="http://phpwebsite.appstate.edu"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}-full.tar.gz"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+RDEPEND="<=dev-php/mod_php-5
+ >=dev-db/mysql-3.23.23"
+
+DEPEND="${DEPEND} ${RDEPEND} >=net-www/webapp-config-1.10-r5"
+
+S="${WORKDIR}/${PN}-${MY_PV}-full"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="docs/CREDITS.txt docs/REQUIREMENTS.txt docs/UNINSTALL.txt docs/THEMES.txt docs/LICENSE.txt docs/README.txt docs/PEARERRORS.txt docs/sample.config.php docs/INSTALL.txt docs/CONVERSION.txt docs/UPGRADE.txt docs/KNOWNISSUES.txt"
+ dodoc ${docs}
+
+ einfo "Installing main files"
+ cp -r * ${D}${MY_HTDOCSDIR}
+
+ #webapp_configfile ${MY_HTDOCSDIR}/conf/config.php
+
+ # Files that need to be owned by webserver
+ webapp_serverowned ${MY_HTDOCSDIR}/conf
+ webapp_serverowned ${MY_HTDOCSDIR}/files
+ webapp_serverowned ${MY_HTDOCSDIR}/images
+ webapp_serverowned ${MY_HTDOCSDIR}/images/mod
+ webapp_serverowned ${MY_HTDOCSDIR}/images/mod/controlpanel
+ webapp_serverowned ${MY_HTDOCSDIR}/mod
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}