summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-03-15 14:35:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-03-15 14:35:22 +0000
commit821aaacd0b62233be1fc030d125c13da4e57856a (patch)
tree3b3935d8a13e5f4f19262958da20c46ad9c76ff6 /www-client/amaya/amaya-8.5.ebuild
parentRemoved insecure version. (diff)
downloadgentoo-2-821aaacd0b62233be1fc030d125c13da4e57856a.tar.gz
gentoo-2-821aaacd0b62233be1fc030d125c13da4e57856a.tar.bz2
gentoo-2-821aaacd0b62233be1fc030d125c13da4e57856a.zip
Moved from net-www/amaya to www-client/amaya.
Diffstat (limited to 'www-client/amaya/amaya-8.5.ebuild')
-rw-r--r--www-client/amaya/amaya-8.5.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/www-client/amaya/amaya-8.5.ebuild b/www-client/amaya/amaya-8.5.ebuild
new file mode 100644
index 000000000000..8e9c212641b4
--- /dev/null
+++ b/www-client/amaya/amaya-8.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/amaya/amaya-8.5.ebuild,v 1.1 2005/03/15 14:35:22 seemant Exp $
+
+inherit libtool
+
+S=${WORKDIR}/Amaya/LINUX-ELF
+
+DESCRIPTION="The W3C Web-Browser"
+SRC_URI="ftp://ftp.w3.org/pub/amaya/${PN}-src-${PV}.tgz
+ ftp://ftp.w3.org/pub/amaya/old/${PN}-src-${PV}.tgz"
+HOMEPAGE="http://www.w3.org/Amaya/"
+
+KEYWORDS="~x86 ppc sparc ~amd64"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gtk"
+
+RDEPEND="
+ gtk? (
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ media-libs/imlib
+ )
+ !gtk? ( x11-libs/openmotif )"
+
+DEPEND="dev-lang/perl
+ ${RDEPEND}"
+
+src_compile() {
+ local myconf=""
+ mkdir ${S}
+ cd ${S}
+ if use gtk
+ then
+ myconf="${myconf} --with-gtk"
+
+ else
+ myconf="${myconf} --without-gtk"
+ fi
+ ../configure \
+ ${myconf} \
+ --prefix=/usr \
+ --host=${CHOST}
+ make || die
+}
+
+src_install () {
+ dodir /usr
+ make prefix=${D}/usr install || die
+ rm ${D}/usr/bin/amaya
+ rm ${D}/usr/bin/print
+ dosym /usr/Amaya/applis/bin/amaya /usr/bin/amaya
+ dosym /usr/Amaya/applis/bin/print /usr/bin/print
+}