summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-09 10:35:31 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-09 10:35:31 +0000
commite9d8adbe6734431a2a6e52051291478e02344eef (patch)
treed0700c0cc7598fba480fa62a88e835f017a426ec /www-plugins/gnash
parentFix bug #284244, src_install() always failed with USE=-nsplugin due to a stup... (diff)
downloadgentoo-2-e9d8adbe6734431a2a6e52051291478e02344eef.tar.gz
gentoo-2-e9d8adbe6734431a2a6e52051291478e02344eef.tar.bz2
gentoo-2-e9d8adbe6734431a2a6e52051291478e02344eef.zip
Fix bug #284073, Use pkgconfig to determine XPCOM_IDL_DIR instead of non-portable construct which fix building against xulrunner-1.9.0, many thanks to Chi-Thanh Christopher Nguyen <chithanh@cs.tu-berlin.de>, Add >=sys-devel/libtool-2 in RDEPEND (not portable to libtool-1)
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gnash')
-rw-r--r--www-plugins/gnash/ChangeLog9
-rw-r--r--www-plugins/gnash/files/gnash-0.8.5-xpcom-idldir.patch18
-rw-r--r--www-plugins/gnash/gnash-0.8.5.ebuild9
3 files changed, 33 insertions, 3 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 00c11fe3c004..9762d0826851 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.8 2009/09/09 10:17:48 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.9 2009/09/09 10:35:30 mrpouet Exp $
+
+ 09 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ gnash-0.8.5.ebuild, +files/gnash-0.8.5-xpcom-idldir.patch:
+ Fix bug #284073, Use pkgconfig to determine XPCOM_IDL_DIR instead of
+ non-portable construct which fix building against xulrunner-1.9.0, many
+ thanks to Chi-Thanh Christopher Nguyen <chithanh@cs.tu-berlin.de>, Add
+ >=sys-devel/libtool-2 in RDEPEND (not portable to libtool-1).
09 Sep 2009; Romain Perier <mrpouet@gentoo.org>
gnash-0.8.5.ebuild:
diff --git a/www-plugins/gnash/files/gnash-0.8.5-xpcom-idldir.patch b/www-plugins/gnash/files/gnash-0.8.5-xpcom-idldir.patch
new file mode 100644
index 000000000000..cdea85df2570
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.5-xpcom-idldir.patch
@@ -0,0 +1,18 @@
+Author: Chi-Thanh Christopher Nguyen <chithanh@cs.tu-berlin.de>
+Subject: Use pkg-config to determine XPCOM_IDL_DIR instead of non-portable construct.
+Bug: #284073
+
+---
+
+diff -ur a/macros/xpcom.m4 b/macros/xpcom.m4
+--- a/macros/xpcom.m4 2009-03-02 16:29:48.000000000 +0100
++++ b/macros/xpcom.m4 2009-09-08 22:02:21.548228034 +0200
+@@ -102,7 +102,7 @@
+
+ if test x"${ac_cv_path_xpcom_incl}" != x; then
+ XPCOM_CFLAGS="${ac_cv_path_xpcom_incl}"
+- XPCOM_IDL_CFLAGS=`echo $XPCOM_CFLAGS | sed -e 's:include:share/idl:'`
++ XPCOM_IDL_CFLAGS="-I`$PKG_CONFIG --variable=idldir libxul`/unstable"
+ XPIDL=$(pkg-config libxul --variable=sdkdir)
+ XPIDL="${XPIDL}xpidl"
+ AC_DEFINE([HAVE_XPCOM], [1], [Use XPCOM in the NPAPI plugin])
diff --git a/www-plugins/gnash/gnash-0.8.5.ebuild b/www-plugins/gnash/gnash-0.8.5.ebuild
index d35248afbdeb..e5f31cfa86c3 100644
--- a/www-plugins/gnash/gnash-0.8.5.ebuild
+++ b/www-plugins/gnash/gnash-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.4 2009/09/09 10:17:48 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.5 2009/09/09 10:35:30 mrpouet Exp $
EAPI="2"
KDE_REQUIRED="optional"
@@ -56,7 +56,8 @@ RDEPEND=">=dev-libs/boost-1.35.0
sdl? ( media-libs/libsdl[X] )
nsplugin? ( net-libs/xulrunner:1.9 )
speex? ( media-libs/speex[ogg] )
- zlib? ( sys-libs/zlib )"
+ zlib? ( sys-libs/zlib )
+ >=sys-devel/libtool-2.2"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )
@@ -98,6 +99,10 @@ src_prepare() {
# Defines $(XPIDL) correctly using sdkdir variable from libxul.pc
epatch "${FILESDIR}"/${P}-xpidl-sdkdir.patch
+ # Use pkgconfig to determine XPCOM_IDL_DIR instead of non-portable construct.
+ # Fixes building against xulrunner-1.9.0, bug #284073.
+ epatch "${FILESDIR}"/${P}-xpcom-idldir.patch
+
# Resurect patch from bug #230287
epatch "${FILESDIR}"/${PN}-0.8.3-boost-dynamic-link.patch