summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-05-15 12:54:00 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-05-15 12:54:00 +0000
commit5ab7156af5626453d82c7ec418434495668c94aa (patch)
tree26f6b3ecb13c5dff69a8b271c16fedde96b91b41 /www-servers/nginx
parentMasked vlc which should use wxGTK 2.6 as it seems not to work as it should. (diff)
downloadgentoo-2-5ab7156af5626453d82c7ec418434495668c94aa.tar.gz
gentoo-2-5ab7156af5626453d82c7ec418434495668c94aa.tar.bz2
gentoo-2-5ab7156af5626453d82c7ec418434495668c94aa.zip
version bump
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest4
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.301
-rw-r--r--www-servers/nginx/nginx-0.1.30.ebuild79
4 files changed, 89 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 99e311d0f8b8..88c9d94fdd66 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.19 2005/05/14 11:51:28 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.20 2005/05/15 12:54:00 voxus Exp $
+
+*nginx-0.1.30 (15 May 2005)
+
+ 15 May 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.30.ebuild:
+ Version bump.
*nginx-0.1.29-r2 (14 May 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 6595ed084c8a..436f8056ba71 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,7 +1,9 @@
MD5 65987f13c01c296f08dd2b66d91f7d1f nginx-0.1.29-r2.ebuild 2061
+MD5 bfcc2f667cc2e6ab0c3db6d6737d7e39 nginx-0.1.30.ebuild 1992
MD5 0b612ee125685634d4e80df6e302d442 nginx-0.1.28-r2.ebuild 2082
-MD5 12fe657a1b8fcb91efce9f4838555547 ChangeLog 3486
+MD5 8c26a2104f5ac5972e01123aa1fa1602 ChangeLog 3608
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
+MD5 3fdafbf9506225d30813bc86bfdfaca2 files/digest-nginx-0.1.30 64
MD5 8c7b8c93f0c4048d83df9cdc31d86e1b files/nginx 922
MD5 964b96268e483e663e4ea13d03320185 files/digest-nginx-0.1.28-r2 64
MD5 4e72c813c956580f61dea414fe1af8b3 files/digest-nginx-0.1.29-r2 64
diff --git a/www-servers/nginx/files/digest-nginx-0.1.30 b/www-servers/nginx/files/digest-nginx-0.1.30
new file mode 100644
index 000000000000..dde9228492cc
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.30
@@ -0,0 +1 @@
+MD5 be5d2300623778292d6e82a8dfc449ba nginx-0.1.30.tar.gz 292612
diff --git a/www-servers/nginx/nginx-0.1.30.ebuild b/www-servers/nginx/nginx-0.1.30.ebuild
new file mode 100644
index 000000000000..5d288f56665d
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.30.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.30.ebuild,v 1.1 2005/05/15 12:54:00 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fastcgi threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+
+ cd ${S} && ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || "failed to compile"
+}
+
+src_install() {
+ cd ${S} || die
+
+ dodir /var/log/${PN}
+ keepdir /var/log/${PN}
+
+ dodir /var/tmp/${PN}
+
+ dodir /var/tmp/${PN}/client
+ keepdir /var/tmp/${PN}/client
+
+ dodir /var/tmp/${PN}/proxy
+ keepdir /var/tmp/${PN}/proxy
+
+ dodir /var/tmp/${PN}/fastcgi
+ keepdir /var/tmp/${PN}/fastcgi
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}