summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-12 16:36:45 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-12 16:36:45 +0000
commit6f8f9e741d57f6fd3859baa76e92f2f97639a784 (patch)
tree65e6ef0a46059f2f55eb41a03769ea01961b95d8 /x11-drivers/xf86-video-rendition
parentFix building against xorg-server-1.14 (diff)
downloadgentoo-2-6f8f9e741d57f6fd3859baa76e92f2f97639a784.tar.gz
gentoo-2-6f8f9e741d57f6fd3859baa76e92f2f97639a784.tar.bz2
gentoo-2-6f8f9e741d57f6fd3859baa76e92f2f97639a784.zip
Fix building against xorg-server-1.14
(Portage version: 2.1.11.52/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/xf86-video-rendition')
-rw-r--r--x11-drivers/xf86-video-rendition/ChangeLog11
-rw-r--r--x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch35
-rw-r--r--x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild17
-rw-r--r--x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5.ebuild4
4 files changed, 63 insertions, 4 deletions
diff --git a/x11-drivers/xf86-video-rendition/ChangeLog b/x11-drivers/xf86-video-rendition/ChangeLog
index 6455fe7d3053..0ad444f95431 100644
--- a/x11-drivers/xf86-video-rendition/ChangeLog
+++ b/x11-drivers/xf86-video-rendition/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-rendition
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-rendition/ChangeLog,v 1.61 2012/12/30 14:49:41 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-rendition/ChangeLog,v 1.62 2013/03/12 16:36:45 chithanh Exp $
+
+*xf86-video-rendition-4.2.5-r1 (12 Mar 2013)
+
+ 12 Mar 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch,
+ +xf86-video-rendition-4.2.5-r1.ebuild, xf86-video-rendition-4.2.5.ebuild:
+ Fix building against xorg-server-1.14
30 Dec 2012; Agostino Sarubbo <ago@gentoo.org>
xf86-video-rendition-4.2.5.ebuild:
diff --git a/x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch b/x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch
new file mode 100644
index 000000000000..77c4d34dea0a
--- /dev/null
+++ b/x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch
@@ -0,0 +1,35 @@
+From 3a3ee1c45e54a808947cc26ca11f0a5299571053 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:50 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/rendition.c b/src/rendition.c
+index 7c74f76..888bb4a 100644
+--- a/src/rendition.c
++++ b/src/rendition.c
+@@ -1173,7 +1173,6 @@ renditionScreenInit(SCREEN_INIT_ARGS_DECL)
+ fbPictureInit (pScreen, 0, 0);
+
+ xf86SetBlackWhitePixels(pScreen);
+- miInitializeBackingStore(pScreen);
+
+ /*********************************************************/
+ /* The actual setup of the driver-specific code */
+diff --git a/src/rendition.h b/src/rendition.h
+index f7f13d4..297117e 100644
+--- a/src/rendition.h
++++ b/src/rendition.h
+@@ -28,9 +28,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ /* All drivers using the mi colormap manipulation need this */
+ #include "micmap.h"
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild b/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild
new file mode 100644
index 000000000000..3c9df5c1101a
--- /dev/null
+++ b/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild,v 1.1 2013/03/12 16:36:45 chithanh Exp $
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="Rendition video driver"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-mibstore_h.patch
+)
diff --git a/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5.ebuild b/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5.ebuild
index 737155668c8e..835bcb7f8994 100644
--- a/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5.ebuild
+++ b/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5.ebuild,v 1.6 2012/12/30 14:49:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5.ebuild,v 1.7 2013/03/12 16:36:45 chithanh Exp $
EAPI=4
inherit xorg-2