summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-03-28 17:52:26 +0000
committerTod Neidt <tod@gentoo.org>2002-03-28 17:52:26 +0000
commit8cfd0b0917b4a43a53ab269333f2f9a0e479709d (patch)
treea7bb05873f5a452ef83a3014167a22c84f26af22 /x11-libs/fltk
parentstable branch of wxGTK added (diff)
downloadgentoo-2-8cfd0b0917b4a43a53ab269333f2f9a0e479709d.tar.gz
gentoo-2-8cfd0b0917b4a43a53ab269333f2f9a0e479709d.tar.bz2
gentoo-2-8cfd0b0917b4a43a53ab269333f2f9a0e479709d.zip
Added ${myconf} to ./configure (doh!). Fixes Bug# 1325. Also fixed goofed SRC_URI in 1.0.11.
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog16
-rw-r--r--x11-libs/fltk/files/digest-fltk-1.0.11-r21
-rw-r--r--x11-libs/fltk/files/digest-fltk-1.1.0_beta10-r11
-rw-r--r--x11-libs/fltk/fltk-1.0.11-r2.ebuild51
-rw-r--r--x11-libs/fltk/fltk-1.1.0_beta10-r1.ebuild52
5 files changed, 120 insertions, 1 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 46eba1257ffc..51173c14b88e 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for x11-libs/fltk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.2 2002/03/28 17:52:25 tod Exp $
+
+*fltk-1.1.0_beta10-r1 (28 Mar 2002)
+
+ 28 Mar 2002; Tod Neidt <tod@gentoo.org> fltk-1.1.0_beta10-r1.ebuild :
+
+ Added missing ${myconf} to ./configure.
+ Bug# 1325, thanks for the catch R. Strusberg.
+
+*fltk-1.0.11-r2 (1 Feb 2002)
+
+ 28 Mar 2002; Tod Neidt <tod@gentoo.org> fltk-1.0.11-r2.ebuild :
+
+ Added missing ${myconf} to ./configure. Also fixed up SRC_URI.
+ Bug# 1325, thanks for the catch R. Strusberg.
*fltk-1.1.0_beta10 (1 Feb 2002)
diff --git a/x11-libs/fltk/files/digest-fltk-1.0.11-r2 b/x11-libs/fltk/files/digest-fltk-1.0.11-r2
new file mode 100644
index 000000000000..cbb63778e7b2
--- /dev/null
+++ b/x11-libs/fltk/files/digest-fltk-1.0.11-r2
@@ -0,0 +1 @@
+MD5 e917767d012bcd8953a5d811e68134ff fltk-1.0.11-source.tar.bz2 999099
diff --git a/x11-libs/fltk/files/digest-fltk-1.1.0_beta10-r1 b/x11-libs/fltk/files/digest-fltk-1.1.0_beta10-r1
new file mode 100644
index 000000000000..f9dacf6cf45e
--- /dev/null
+++ b/x11-libs/fltk/files/digest-fltk-1.1.0_beta10-r1
@@ -0,0 +1 @@
+MD5 58cbcab46f925e74ec978803d4064381 fltk-1.1.0b10-source.tar.bz2 1087535
diff --git a/x11-libs/fltk/fltk-1.0.11-r2.ebuild b/x11-libs/fltk/fltk-1.0.11-r2.ebuild
new file mode 100644
index 000000000000..d0efc7fb041d
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.0.11-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /space/gentoo/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.0.11.ebuild,v 1.2 2001/06/04 00:16:12 achim Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+
+SRC_URI="ftp://ftp.fltk.org/pub/fltk/${PV}/${P}-source.tar.bz2"
+
+HOMEPAGE="http://www.fltk.org"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+ #shared libraries diabled by default
+ myconf="--enable-shared"
+
+ use opengl || myconf="$myconf --disable-gl" #default enabled
+
+#Learned '${prefix}' trick from studying python ebuild
+#There are no info files
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc CHANGES COPYING README
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/fltk/* ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/share/doc/fltk
+
+}
+
diff --git a/x11-libs/fltk/fltk-1.1.0_beta10-r1.ebuild b/x11-libs/fltk/fltk-1.1.0_beta10-r1.ebuild
new file mode 100644
index 000000000000..cfac687a257a
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.1.0_beta10-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /space/gentoo/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.0.11.ebuild,v 1.2 2001/06/04 00:16:12 achim Exp
+
+MYVER=${PV/_beta/b}
+S=${WORKDIR}/${PN}-${MYVER}
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+
+SRC_URI="ftp://ftp.easysw.com/pub/fltk/${MYVER}/${PN}-${MYVER}-source.tar.bz2"
+
+HOMEPAGE="http://www.fltk.org"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+ #shared libraries diabled by default
+ myconf="--enable-shared"
+
+ use opengl || myconf="$myconf --disable-gl" #default enabled
+
+#Learned '${prefix}' trick from studying python ebuild
+#There are no info files
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc CHANGES COPYING README
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/fltk/* ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/share/doc/fltk
+
+}
+