summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 01:02:18 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 01:02:18 +0000
commiteebab6d6e8a7f3457179b8bfd649a412e3d183ec (patch)
treec74122f2cab6eb3a89f0b81a1e6825a357853592 /x11-libs/gtk+
parentInitial import. Closes #47007. (diff)
downloadgentoo-2-eebab6d6e8a7f3457179b8bfd649a412e3d183ec.tar.gz
gentoo-2-eebab6d6e8a7f3457179b8bfd649a412e3d183ec.tar.bz2
gentoo-2-eebab6d6e8a7f3457179b8bfd649a412e3d183ec.zip
fix aclocal warnings
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/files/gtk+-1.2.10-m4.patch9
-rw-r--r--x11-libs/gtk+/gtk+-1.2.10-r11.ebuild28
2 files changed, 22 insertions, 15 deletions
diff --git a/x11-libs/gtk+/files/gtk+-1.2.10-m4.patch b/x11-libs/gtk+/files/gtk+-1.2.10-m4.patch
new file mode 100644
index 000000000000..37fb7c263096
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-1.2.10-m4.patch
@@ -0,0 +1,9 @@
+Fix aclocal warnings:
+/usr/share/aclocal/gtk.m4:7: warning: underquoted definition of AM_PATH_GTK
+--- gtk+-1.2.10/gtk.m4
++++ gtk+-1.2.10/gtk.m4
+@@ -6,3 +6,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_GTK,
++AC_DEFUN([AM_PATH_GTK],
+ [dnl
diff --git a/x11-libs/gtk+/gtk+-1.2.10-r11.ebuild b/x11-libs/gtk+/gtk+-1.2.10-r11.ebuild
index bea102b24ac7..01f47bd4404e 100644
--- a/x11-libs/gtk+/gtk+-1.2.10-r11.ebuild
+++ b/x11-libs/gtk+/gtk+-1.2.10-r11.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r11.ebuild,v 1.17 2005/03/21 03:42:32 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r11.ebuild,v 1.18 2005/04/29 01:02:18 vapier Exp $
GNOME_TARBALL_SUFFIX="gz"
-inherit gnome.org eutils libtool gnuconfig toolchain-funcs
+inherit gnome.org eutils libtool toolchain-funcs
DESCRIPTION="The GIMP Toolkit"
HOMEPAGE="http://www.gtk.org/"
@@ -11,7 +11,7 @@ SRC_URI="${SRC_URI} http://www.ibiblio.org/gentoo/distfiles/gtk+-1.2.10-r8-gento
LICENSE="LGPL-2.1"
SLOT="1"
-KEYWORDS="x86 ppc ~sparc mips alpha arm hppa amd64 ia64 ppc64"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~sparc x86"
IUSE="nls debug"
RDEPEND="virtual/x11
@@ -22,26 +22,24 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
- cd ${S}/..
- epatch ${DISTDIR}/gtk+-1.2.10-r8-gentoo.diff.bz2
+ cd "${S}"/..
+ epatch "${DISTDIR}"/gtk+-1.2.10-r8-gentoo.diff.bz2
# locale fix by sbrabec@suse.cz
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.2-locale_fix.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2-locale_fix.patch
- # Required for Mac OS X
- gnuconfig_update
+ elibtoolize
}
src_compile() {
- elibtoolize
-
local myconf=
use nls || myconf="${myconf} --disable-nls"
- if use debug
- then
+ if use debug ; then
myconf="${myconf} --enable-debug=yes"
else
myconf="${myconf} --enable-debug=minimum"
@@ -57,7 +55,7 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die
preplib /usr
@@ -70,7 +68,7 @@ src_install() {
#install nice, clean-looking gtk+ style
insinto /usr/share/themes/Gentoo/gtk
- doins ${FILESDIR}/gtkrc
+ doins "${FILESDIR}"/gtkrc
}
pkg_postinst() {